Hi, I am running Cubase 8.5 on OS X 10.8.5.

I installed the Mac USB driver for the JDXI and I can see it’s being detected by the system and software. I am able to see the JDXI listed as an option under the ASIO Driver under VST Audio Option in Cubase.

My problem is, I can’t figure out how I can record the JDXI and also monitor what I am playing along with the rest of the track. I use a NI Komplete Audio 6 for playback. The JDXI is plugged directly into the Mac via a USB cable. According to the Roland support site, I should be able to record into a DAW via USB.

Should the JDXI show up under VST instruments?

My guess is that you did not set the keyboard to “local off” as stated in the JDXI operation manual (page 15). The procedure to set that parameter is on page 12.

Also, with that setting, you will need to assign a VSTi from what you have available in Cubase. As an example choose something like Halion SE and choose a sound like piano. Make sure that sound is activated.

Report back if that is not the issue. Good luck

Regards :sunglasses:

I think your options are:

  1. Select it as the soundcard, configure inputs AND outputs to be the JDXI and then monitor everything via the JDXI headphones socket.

  2. Create an aggregate audio device in the Mac and select that as your driver then you can use JDXI inputs but KA6 outputs. You can google Mac aggregate device for instructions.

thanks will try both things.

Yeah. This is what it seems like to me. (I was hoping I was wrong.)

Once I change the sound device to JDXI, then the Komplete disappears, so you can’t use it in Cubase anymore – and the monitors and the other stuff is all hooked via the Komplete.

Well that’s why you would use option 2 then.

thanks. that worked. I used the instructions from the link below. I had never heard of an aggregate device.


Hello guys, can u please tell me how to CHANGE JDXi BANKS & PRESETS from Cubase ? Or is there any patch script ?