Jitter in midi clock

I send the midi clock from cubase 11 pro to my hardware roland system-8 and I experience a lot of jitter in the clock, which results in glitches in arps and timed fx. After monitoring the clock it differs between + and - 1 bpm in 4 bars.
BTW when sending the midi clock from midi-ox it is the same problem, so probably my windows pc cannot produce a steady midi clock.
But what can I do to get a stable clock. Are there specific settings that can be done in windows or should I search for a hardware sollution? I’m looking for tips.

Hi and welcome on the forum,

I’m not MIDI Clock specialist at all. But I’m afraid, this might be result of the USB-MIDI jitter. USB protocol is really far from the best for the real-time MIDI data transfer.

Are you plugged directly into a USB port on your computer or are you using a hub? You should plug directly into your computer.
If you have a Thunderbolt or Firewire audio interface with MIDI ports use those. They get around the frame rate issue with USB MIDI.
Some discussion here:

Might check in with these gguys
https://kentonuk.com/

Best

I forgot to mention I’m using a steinberg midex 8. The roland system-8 can use both midi and USB. But in both cases the midi clock flows around. Maybe a bit more using usb.

Hi,

Yes, the Steinberg midex 8 is connected via USB to your computer. So it is dealing with the USB Jitter issue.

Right. I have been using the midex for more then 20 years and experienced any problems. Only since using the system-8 with timed fx this became obvious and looked into this,
But is there a solution going around usb midi? Dedicated midi card or something?

Hi,

Unfortunately not really in nowadays. The last real “MIDI cards” where the old one with the Gaming Port. Today, other but USB protocol might work, like Firewire. Or use an external sync.

As a last option I have tried the midi interface on my RME HDSP pci card. But unfortunately that doesn’t change a thing in the stability of the midi clock. Still + &- 1 bpm over 4 bars.

Hi,

That’s interesting, PCI card shouldn’t be affected (great hint!).

A bit of an expensive option. But I use an Innerclock Systems Sync Gen II Pro. It doesn’t use midi out of the computer, it uses audio out of the computer, and use up two of your audio outputs. In your DAW, you run their plugin which sends audio pulses out to the hardware unit. The Hardware then has 5 Midi and 5 Din Sync outputs to clock hardware. It also has a pulse output to drive modular. It’s about as tight as you can get.

He doesn’t make Sync Gen II Pro’s any more but you can get them used and he is updating the plugin, and used I think they are around $550. I believe Sync Gen III is coming out soon, but not sure.

Found this:
https://www.e-rm.de/midiclock/
$195

Haven’t used it, but they published a pretty technical white paper if you want to dive in:

In the midi setup of cubase you have an option to choose directmusic ports Have you tried that? Or if you already have that ticked untick it. Could be an issue with a windows timers.
Also are you 100% sure it is the clock and not the Roland? Some devices and even some plugins have troubles with tempo synced items like delays or arose running from external clock. Sometimes I will just set the device or plugin to the exact tempo if an arp or ms if a delay and not use sync.
I have been occasionally running a microfreak a sub37 and Arq on external clock and heard no issues. It was difficult to set up, all kind of conflicts and start stop command issues.

Thank you all for sending me in this direction. I will dive in the suggested solutions.
And the suggestion that maybe the roland isn’t that stable afterall is a good one aswell. I will also look into that.