JST Bassforge plug-in froze Cubase

I just purchased and installed the Joey Sturgis Tones Bassforge Hellraiser plug-in. However when I then scanned for the plugin in Cubase 10, the process froze Cubase. The VST scan process just said “scanning” and never moved. Then I realised Cubase had become completely unresponsive.

I had to manually abort Cubase. Then when I tried to re-launch Cubase, the application would not complete initialisation. It was caught up on “Scanning for VST3 plugins” during initialisation and would not progress beyond this.

I then uninstalled the JST plug-in and Cubase once again worked. I repeated the installation of the plugin and same result, Cubase would not initialise, caught up on scanning for VST3 plug-ins. I then uninstalled the plug-in again and Cubase back to normal.

Any ideas what is going on?


Do you have the latest plug-in update installed, please?

I would recommend to inform the plug-in vendor.

Is the plug-in update installer you speak of a Steinberg or plug-in vendor application?

I’m still going back and forth with vendor, plug-in still freezes Cubase.

Tried an updated version of the plug-in that was suggested after I registered problem. This version is quite new I’m guessing as I only purchased & downloaded previous iteration a couple days ago. However same result, Cubase won’t initialise.

Hopefully I can solve this.


I mean the JST plug-in vendor.

Seems it may have been a problem with iLok. I hadn’t updated to the most recent version, which is quite recent. Once I did this the problem went.
Either that or I installed too many components, rather than just the VST3 64 bit.