Jump automation -not quite- instant?

Ive asked this numerous times over many many years, but never got a proper answer from anyone…so I’m asking again (maybe 7 years after my last ask)

But is there a way to make “jump” automation actually be instant?
There is always a very very slight ramp up time, which you can actually see if you zoom right in on the automation lane…see my attached image.

You can never get the points to be perfectly ontop of each other.

If I use the line tool (with shift) to draw square wave type blocks, the little ramp up isn’t shown…but is deffinately still there/audible.

I know this sort of automation works as I expect in Reason, but Cubase (since I’ve been using it from like version 4) has always had this ramp up/down time.
It’s particularly noticable if you automate a filter up, and then do a hard cut back down.
I used to call it “knob move simulation”… is there any way to get a true instant jump, or is it just not a possiblity?

Ive recently been playing around with a retro sampler vst called “Amigo” and want to hard automate pitch changes and phase changes on drum hits…but it’s just ever so slightly, not instant…and so it’s sounding less tight. It’s probably a matter of ms, but it IS noticable.

My workaround has always been to just have multple instances of tracks I want to do this on, and fake it that way…but that doesn’t feel optimal.

Go,

In any case, you can type the value (Start Position) in the Info Line, so you can type the same value.

Yeah, that’s not the issue. You can manually type in the values for the ammount, but you can never have a point, directly above a point it seems.
They -look like- they are, until you zoom right in.

Is this a limitation of the MIDI reolution (920) ?

No, there is no MIDI involved in VST automation.

I can’t see a ramp. I have zoomed in as far as it goes, ruler is set to samples to demonstrate zoom level.

Oh weird!

Wonder if I have a setting different to you somewhere.
I went into the automation panel settings, and made everything that seemed relevant there to be as low as possible. But couldn’t see anything else anywhere.

Hi,

I tried to st the Ruler to Samples. Then I Zoomed In as much as possible. I can put 2 nodes at the same sample position in the Info Line, but visually, there is always a ramp.

Screen Recording 2024-03-28 at 10.18.59.mov.zip (735.1 KB)

My findings in Cubase Pro 12.0.70 is that Cubase defaults to having a minimum of 1 sample separation between nodes. I can however change this in the Info Line.

automation node

I really question this. Even in a “low” sample rate of 44.1kHz, the length of one sample is less than 0.023 ms. In 96kHz one sample equals close to 0.01ms (or 10μs).

I guess it’s a combination of that, and the latency of the plugin.

To hear it in action, take any decent 3rd party filter plugin (I use Philta XL) draw in an automation curve, then do a hard drop back to 0 (or very low)…it’s 100% NOT instant, and you will hear it blip before hitting the low point you set.
It’s less audible with stock plugins, but it’s still there.

Here is an export I have just done to demonstrate (this is also with Philta XL in it’s lowest latency “inertia” type mode it’s worse at stock values)

https://drive.google.com/file/d/1rk48n-pMg1lZtOjvD7uxwQpU5pgLt9sB/view?usp=sharing

Hopefully that demonstrates my issue to some extent

hmmm. this looks different in 13

If I try to set the two "1"s in there , they don’t change, but am assuming it’s the final number that’s important.

Change your main ruler from Bars & Beats to Samples.

Yes, sorry, didn’t notice that.
It’s deffinatly -better-, but still has a bit of a blip when the automation jump happens in my filter example. Will try using the retro sampler I was testing out when I get a couple of mins to see if it helps with that.

It still feels like cubase is emulating the knob movement (regardless of how quick you force it to happen) rather than it being an instant jump though.
Like I say, I’ve been fighting with this since about version v4 (it probably did it in sx3 too) and have never got a satisfactory outcome.

I came from reason (3.5) to Cubase, and it’s one of the things I still miss about how Reason handles it.

Here are my findings using white noise as a source with volume automation.
It doesn’t show in this screenshot, but the volume automation nodes had the same value expressed in samples.


Looks like about a 10ms ramp (≈530 samples in this example with a project set to 48kHz sample rate).

Volume Automation Precision was set to the default value of 8 samples.
image


I’m not sure what Steinberg means by “sample accurate volume automation”, something that should’ve been introduced in Cubase 12.


Full article

@Martin.Jirsak Any thoughts about this? Am I missing something obvious?

Strange,

here is my result with Cubase 12.0.60 on PC.
I did the same kind of volume automation as you.
SineWave (the irregular nature of white noise makes it hard to see where exactly the ramp starts). Precision also set to 8 samples.

I get exactly 8 samples.

Here is the same setting but with Automation Precision set to 4 samples:

I get the little ramp, too. Funny, the second node is not 1 sample behind the first one but 0.5 sample.
grafik

However, this should not be the cause of hearing any delay of automation. The root cause must be something else.

As mentioned…this is something that’s bugged me for years, and no one has ever really come up with a good reason, let alone any kind of solution, other than…it’s a lot better when using included plugins rather that 3rd party…which is…meh!

As a test, here is a similar loop as I posted earlier, but using Steinberg’s “dual filter”

https://drive.google.com/file/d/1mLINLdXt-bOB8M_HU8NVVo1rVDdHxQiv/view?usp=sharing

For comparison, here’s the one from earlier using a 3rd party filter plugin
https://drive.google.com/file/d/1rk48n-pMg1lZtOjvD7uxwQpU5pgLt9sB/view?usp=sharing

Definately different behaviour…or at least the effect is a lot less pronounced as to be not noticeable.

Interesting. I will have to try with a sine wave as well. What frequency did you use in your test?
You’re right, it’s hard to see exactly how long the ramp is, but it’s clear that it is way longer than 8 samples.
I used the TestGenerator plug-in to generate the white noise that I then exported to an audio file. Mostly for visual clarity.