Jump Bar error while duplicate to staff above/below

Also, to the dev team: I’ve just tried this using my new HP laptop, and with build 1082 it will only work one time. IE-- I add notes, use the jump bar and type “duplicate to staff above” and press enter, and it duplicates the first time, but when I then press j a second time with the entry auto-populated and press enter, nothing happens. This was using the String Quartet template. Diagnostics attached.
Dorico Diagnostics.zip (309.3 KB)

This is a result of getting arrogant responses more than helpful ones. Not in this post only.
And thank you for half confirmation that there is something buggy. You are the second man who have ability to understand the question in thread’s first post… “Can anyone confirm?” So thank you again! :slight_smile:

How I avoid this bug? I just delete the last character of auto-populated text and this gives me a list again, where I click on single option that matches. Easy! One click more or less, who cares? The same we could reach without JumpBar.

Arthur,

I think it could be worthwhile let this discussion rest for a while and come back later.
I, too, am thinking that none of the responses you got were arrogant or meant this way. You somehow took it the hard way.
As for myself, I am not often on the forum, but I can say I always experienced Leo to be very helpful and positive. I’m sure you will come to the same conclusion after some re-reading and re-evaluating. Unfortunately we cannot see each other’s faces, that would have helped avoid this misunderstanding.
Thanks for reporting the bug and

Cheers, Eddo

2 Likes

And… whoever put the “Solved” mark to Dan’s comment – are you sure it belongs there?… :wink:

In that context - yes, sure. But I can remove it if you think that someday after many years here can be a real solution :slight_smile:

And thank you for your comment. It helped to get rid of angry.
And yes about faces. Virtual presence is killing humanity. Therefore I always put my real face in profile just to be and look more responsible on what I’m talking.

1 Like

Today I accidentally solved this problem.
Firstly I will remind the flow I can reproduce the bug - I open Classic Orchestra template and put a single note for oboe in second bar. Then I press J for JumpBar and start typing phrase “Dupli…” so I can select “Duplicate to Staff Above” with the mouse from the list. It copies selected note to staff above. It’s okay.

Then I press J again for JumpBar - it has the same command filled in a field and I press Enter. It copies already duplicated note back - down (I have double note for oboe) as if I was select “Duplicate to Staff Bellow”. Next time I open JumpBar it shows “Duplicate to Staff Bellow” which I never selected.

@pianoleo responded that he was unable to reproduce this bug and I start thinking it is because the way through updates and testing workflows are different for us.

Today while I testing Ctrl+Z (Undo) bug someone reported, I tried again to reproduce my “beloved bug” with JumpBar and as I wrote above I can replicate it. Then, I would say it happened accidentally, on a second step when the selected note is duplicated and on next try it would duplicate back, I just “walk” in JumpBar’s list (without expanding it) with keyboard key Down (it expands the list) then Up and Down to select “…Bellow” and then “…Above” again. Then I press Enter and it copies above.

Since then I cannot replicate this bug and we can assume that it is solved. How? Let’s ask developers/programmers - what was missed in JumpBar’s function that caused this bug and what was fixed after I walked through list with cursor keys? Some kind of ID stored temporarily or permanently and was lack of it until cursor key actions?

Now even I select Above or Bellow with mouse click, it works as expected.
So if someone has the same behavior, try to select options with cursor keys.

Thank you both, @pianoleo and @dspreadbury for your patience :wink:
EDIT: removed “solution”, because nothing’s solved. (and I also have patience! …limited, of course)

Hi @ArthurNeeman,

I’ve just tried to do exactly what you’ve described and, unfortunately, it works as expected for me. NB In the Classical Orchestra template the Oboe is the second instrument from top i.e. when I duplicate above Oboe, it duplicates to Flute. When I do the same again, it doesn’t/can’t duplicate above again (and doesn’t duplicate below either).

Maybe this was the key? Once Dorico cannot duplicat above first staff, it somehow fixed things and since then works perfectly. So as I specified above this post has a solution.

Some strange things also happened with Cubase - C12 was working perfectly until I installed C11 (just for test some old features) and then had problems in C12 with graphic card drivers. Then I uninstall C11 and now C12 is working perfectly again. The C11 before C12 installed was working more than perfectly! Who can explain this? No one. So systems get bigger and also issues and bugs are growing.

The fun is in that I at last tried the same on “Duplicate to staff bellow” and it has the same behavior - first execution of command duplicates selected notes bellow, but after recalling JumpBar window and just press Enter with no changes in input field, duplicates selected notes above so have doubled each note. Then I did the same as I described earlier - use cursor keys (down/up) to open list and then select “…below” after it erroneously showed “…above”. And now it works correctly.

So, again - @dspreadbury and @pianoleo, before navigating with cursor keys, there is something missed in functionality. I would say that ID of list item isn’t stored somewhere where it should be. I suppose that those users who cannot replicate this bug, already used cursor keys at very beginning of JumpBar life so they have all things correct. Who knows…

EDIT (after 2 hours of composing including JumpBar functionality):
It’s like a weather - every day it’s different. Now I can replicate this and at some point it is annoying while composing. While testing, it’s fun of course, because cannot figure out what causes it. Anyway it seems that selecting an option/command in JumpBar with mouse and cursor keys is different.

Here are two scenarios I can reproduce:

A)

  • Open a template, add whatever meter/notes.
  • Select notes.
  • Press J and begin typing “duplicate”.
  • Press enter (or click) on Duplicate to Staff Above. It works and the duplicated notes should now be selected in the stave above.
  • Immediately press J again. The Jump Bar should display “Duplicate to Staff Above”. Press either Enter, or Right-arrow and then Enter. Items are now duplicated down a stave.
  • If you press J again, the Jump Bar will now list “Duplicate to Staff Below”.
  • If I keep pressing J and Enter notes will keep duplicating below.

B)

  • Open a template, add whatever meter/notes.
  • Select notes.
  • Press J and begin typing “duplicate”.
  • Press enter (or click) on Duplicate to Staff Below. It works. The duplicated notes should now be selected in the stave below.
  • Immediately press J again. The Jump Bar should display “Duplicate to Staff Below”. Press either Enter, or Right-arrow and then Enter. Nothing happens - the previously selected notes remain selected.
  • If I now push J again, the Jump Bar is empty.
  • If I push Enter after this, Condensing is switched on. ( I don’t know why but I feel like the Condensing is something specific to do with my previous use and not likely to happen for all users).

Funnily enough, in Scenario A, when I do other tasks and then decide to use the Jump Bar again, “Duplicate to Staff Below” is still listed and works as expected upon pressing Enter.

I tested this in two completely new templates as well as a previous project, restarting Dorico before each. If I knew how to do those GIF-thingys I would do so.

1 Like

Try this - if after erroneous duplicate you still continue to duplicate it (not even in the direction you want) and reach the upper staff from where it cannot duplicate anymore, on further duplicate tries it works as expected - if above it goes above, if below it goes below.

EDIT:
I also tried two similar commands - Move to Staff Above and Move to Staff Below (from JumpBar, not key commands Alt+N and Alt+M). The moving up works as expected, but moving down stops after one execution. JumpBar’s input field is empty - no previous command shown. Despite that the Alt+M still works. After selecting Move to Staff Below again, it’s the same - works only once, then field is empty.

On a test project selecting everything and delete, then add time signature and try to do the same things - everything works as expected - also Move to Staff Below works many times from JumpBar.

I know tomorrow it will change again :slight_smile:

Nothing’s changed in 4.3.0.1110 (Nov 13 2022)

Tested on both my studio computers.

If it would be understandable that my laptop (Ryzen 5, 2 GHz, 20 GB) is too poor for such cosmic operation beside of small composer tools like Cubase and WaveLab that runs very well on my calculator type laptop, but in October I bought i7 11700 kf and also on that machine Dorico gives me the same behavior.

So, @pianoleo, tell me what’s wrong with my workflow? I upgraded to v4 almost only because of this beautiful feature - Jump bar.

Additionally
Also some other commands don’t work as expected. For example Move Right by Grid Value - if I choose it in Jumpbar, one time it works, then on next call it won’t execute it. Doing the same with keyboard shortcut (Ctrl+Alt+Right) works as expected.
Also Move to staff bellow works only once from Jumpbar, the next time I call Jumpbar and press Enter, it somehow turned into Move Down and does nothing.
Those tests I did on i7.

Someone said that soon all problems will be fixed. Probably it was in my dream - there someone from Dorico team was Santa Claus :smiley:

Just because the things you wanted didn’t change does not mean that “nothing’s changed.”

1 Like

I hate to put my foot in it but I’m not sure where you read this? I couldn’t find a statement like that from anyone from Steinberg in this thread.

We are aware that this problem still occurs sometimes, but as yet we’ve been unable to reproduce it reliably enough to fix it. It’s certainly still on our list of things to address.

2 Likes

We are in a topic with strong statement. So, in this context really “nothing’s changed”. If you just need to talk with someone about weather and health, please use appropriate threads.

Peace!

@dspreadbury, but how is it possible that I can reproduce it on very fresh computer bought almost for one big purpose - Dorico! - to avoid errors probably occurred only on my laptop while working in Dorico. It’s now i7 11700 kf. Should I buy i9 for Dorico while Cubase and WaveLab is good for me on Ryzen 5? Where is guarantee that the same errors won’t be on i11?

What should I do? Jumpbar really helps and all new features since first Dorico 4 release are good enough to not to go back to 3.5, therefore such mistakes are very annoying.

Now I’m working on music for my short film and of course I’m accustomed to the erroneous Jumpbar and after a while it will be taken in count as cripple and as always, we can be tolerant. But nobody can say to me that this is normal.

I know that opening list of commands in Jumpbar and selecting from that list can avoid this error. But as we know Jumpbar is for quick workflow, not the same as going through deep-leveling menues. It means that if I need to execute one command 20 times, I could press J and Enter and this is way faster than a sequence - “J” + Down Arrow + Up Arrow (not once) to select + Enter and so on.

And, Daniel, thank you and your team for Alt+U :slight_smile: It’s gorgeous!

I have seen the problem myself from time to time, but I don’t know what steps I need to take in order to reproduce it reliably, which means that I can’t catch it in the act in the debugger and find out what’s gone wrong. We certainly plan to fix it, but unfortunately we can’t fix bugs we can’t reliably reproduce. I know it’s frustrating – it’s frustrating for me too (since I was the one who implemented the jump bar, and I would prefer it to work 100% reliably).

4 Likes

Did you get a chance to try the procedure(s) I listed above? These produced a problem consistently… for me…

1 Like

I did try the procedures you provided, Daniel, but they didn’t allow me to reproduce the problem reliably. However, I’ve spent some more time looking into this tonight and I believe I have an improvement that should address this satisfactorily in future.

2 Likes