'Jumping' Track Selection

For a while now Cubase has behaving strangely when I name or select tracks. It will suddenly jump to another track in the project window, either after I’ve pressed ‘return’ when naming a track, or sometimes when I select a track, it will jump to the one below.

It appears to be random and intermittent. Sometimes I can go a whole session without it happening, other times it’s like there’s a second person with a mouse trying to control Cubase! Often a restart will fix it.

Any ideas what could be causing this?

If you’re using an external controller and you’re naming your tracks the same thing then you’ll get behaviour like you’re describing. Best to make sure every track is named differently.



BV 01
BV 02
BV 03
BV 04

Thanks for the tip Manike.

I’ve got a really large template, with many orchestral libraries. So I’ll tend to name them as…

NAME - Instrument - Articulation

The first and second words will be repeated a lot, but the combination of all three will always be unique. Would this still cause the issue?

not sure - maybe. Might be worth experimenting with. Or at least unplugging whatever controller you’ve got hooked up and seeing if you still get the problem.

Thanks Manike, will do.

I am experiencing this as well (Cubase 9.5.30)

Has anyone experienced similar? It’s true that it only starts happening when I’m building up a lot of tracks in the project. If I start an empty project and add a few audio tracks, for example, the track selection is proper.

The jumping around is really hurting my workflow (and eyes).

Would be glad to hear if someone got to the bottom of this issue?

Might be that your mixer isn’t in sync ( linked ) with your arrange page?

For me it was my Nektar controller keyboard, I could only stop the jumping by uninstalling the software that came with it. As mentioned earlier in the thread, apparently it’s connected to track naming confusing the controller.

thanks for suggestion but this was not it

ok - thanks! This sounds like it could be it.

An easy way to sort this problem would probably be to just not use mixconsole 1 as your main mixer. Use 2 instead and just have mixconsole 1 as inputs or something similar.

The Nektar thing is an issue. I have a Panorama P1 and you have only 4 spaces for a name so you have to be a bit creative there. It doesn’t happen if you don’t use the controller.

It’s taking the names from mix console 1. Use another as your main mixer. Use 1 as your inputs or something useful to you that has fewer channels.

Aren’t all mixers displaying the same track names? I didn’t think you could have separate names for the same track on different mixconsoles.

The track names themselves are the same but if you aren’t displaying the audio tracks in mixconsole 1 - only VCAs or Groups or Input channels then you wont have the problem of the Nektar going ape when it thinks you’ve got dual names because most of the names aren’t being displayed. Ie it’s taking the names from mixconsole 1 - so reduce the amount of names you have in mixconsole 1 is what im saying.

Makes sense, thanks:)

Hi All,

I am having this problem as well, but I have a fix for this.
Since Nektar is using the option to auto select a track when moving a slider from the mixer panel, just untick the option, “Enable Auto Select” (Studio > Studio Setup > Nektar Panorama x) See Attachment.

I hope this will help some of you!

Alle the Best and happy making music!
Nektar T4.JPG