Just got a QC and... what can I use it for since...

Love the CMC. Yeah I finally jumped to buy the QC and the TP, but came to find out that the QC doesn’t properly work on C7. Is it just the channel EQ that doesn’t work on the controller, or there is something else I should know about.

Anyway, can someone point me on how do I customize the function of the F1-F8 on the QC? Oh. and how do I “unlearn” a nob? I started moving nobs around and kind of messed up a project. Anyway, is there a more detailed manual??


hahah sorry I’m just new to the CMC’s…

to get the QC to work with c7 you need to download and install your latest tools and firmware and then you EQs will work fine .
To assign key commands to the function buttons you QC is listed in Tab > Devices and you can assign your key commands to your function buttons there :wink:

Oh thanks…

Did all that, Still not working.

Could I be doing something wrong??

so you have updated the firmware to version 1.11 and installed the version 1.1.2 tools and then a cold reboot after ?

I even tried downloading the file again. this is what I get when I try to install it again.

your installing the wrong firmware you want version 1.11 not 1.10

are there options on the download file? I’m downloading that file with the 1.11 but get that 1.10.

did you follow the update instructions ? it looks like the correct version downloading , for some reason it’s just not installing in your cmc . Have you only got the QC plugged in as I think you can only update one at a time ?

the first time I tried I had both the QC and TP. Later tried with just the QC and I keep getting that message.

sorry I don’t know what else to suggest , when moving over from c6 to c7 we had to wait for the new firmware and TOOLS to be released to have the eq’s working with c7 but the firmware and tools both installed effortless

It looks like the upload file isn’t the latest version…?

I take you have activated both in the device > setup >left click the + at the top left and chose the cmc’s ?

how very odd

Yeap… did you notice that QC says 1.10. Actually only the PD has the v1.11

In the setup… the TP wouldn’t show up when I follow your instructions. the QC was already there.
Thanks a lot…

I maybe wrong but I do believe that is the latest version and the one before has all the controllers on 1.10

have you defiantly installed the tools 1.1.2 ???


It works now. I re-installed everything from zero, and re-booted my pc after even trying it.

Thanks G-string. I’m also having trouble finding the channel settings window under the options to setup in the special function keys. LIke I’d like to open the selected channel settings windows with the F1 key.

Thanks again.

excellent ,im glad you got there in the end :wink:

To setup F1 for your channel edit window follow TAB Devices > device setup > Steinberg cmc qc > F1 > (drop down box )category :Edit > Edit channel settings

hope this helps and enjoy the qc :slight_smile: