Just one repeat ending

I would definitely like to add this as a feature request then. I just briefly looked and couldn’t find an example that I’ve had to engrave before, but I know there have been many instances when I’ve had to adjust a dot vertically, especially to avoid possible confusion with adjacent notes. Take Gould’s example on pg 58:

Unless I’m mistaken, the only way to do that in Dorico is by switching voices there and flipping the stem, right? It would be great to add a feature in the Properties panel to allow the dot to be edited vertically as well.

It’s of course been requested before, but it’s not easy to achieve because there is no direct correlation between a single note and its rhythm dot, due to the fact that dots belonging to multiple notes can be grouped, and in dense chords some dots will not be drawn. Therefore setting the position of a rhythm dot cannot in general be done directly in a way that is guaranteed to give predictable results. It’s on the backlog.

I am really confused. Is this about dot placement or non-repeat endings?
Perhaps if someone would translate the German for me, I could better understand what HeiPet is after.

LOL, non-repeat endings. It was just when I tried to replicate his sample image exactly, I realized that it wasn’t possible to exactly reproduce his augmentation dot placement either. (I agree with Daniel that the dot placement in his image is “wrong,” but I’ve often been asked to do things by composers or publishers that I don’t agree with, so it’s good to have the flexibility to execute their wishes.)

Daniel is correct: I mentioned this dot issue a looooong time ago and it does in fact have legitimate uses!


Daniel, with the new line editor, I am now able to create a line, which looks exactly like a repeat ending. A bit of work, but now it is al least doable. Thanks!

If you look at my new line on the first staff, it is placed in standard position and as you can see, the end hooks don’t match the position of the barline by default. Is there a setting I overlooked, to align the line with the barline by default?
One Repeat Ending.dorico.zip (524 KB)

I’ve not opened your project to check, but I would expect that provided you set the attachment options for the start and end of the line to ‘Barline’ in the Horizontal Lines panel before you create your line, it will then snap to the barlines as you expect.

They are set to snap to barline,which they do. But only quite …

Here is a picture of what I am seeing. So you don’t need to look at the file.

That’s what I’d expect.

You expected, that the hooks are not aligned to the barlines?

They may not be centred on the barline, but they are most certainly aligned to the barlines.

But that is not really useful, because one always have to do some manual adjustments. In this case I want to ask again for a possibility to have only repeat ending. They are always perfectly aligned.

Hello HeiPet,
I am reading this post with interest. Can I just ask: In the Fine example you gave, did you need to do anything special with the vertical position of the “Fine” text. I have been trying to do something similar, but my text appears a little higher relative to the line. Maybe I have not quite got the hang of this yet.
Geoff D.

Hi, Geoff, open my file and in Engrave mode open the Editor for Line annotations. In the text category you will find “Fine”. There you can see the values I used. If I recall correctly, I changed the value above to 3/4 instead of 1/8 an I used the font style for repeat endings.

Hi Heipet,
For some reason I am struggling with the “One repeat ending” file you attached (I get a zipped up folder, but not something I seem able to do anything with - maybe it is a mac vs windows thing…), - in any case, I shall play some more with the options.
Geoff D.

Heiko will have just uploaded the Dorico file itself, changing .dorico to .zip, rather than zipping up the Dorico project. So change the file extension of the downloaded file from .zip to .dorico and it will open in Dorico directly.

Ah - thanks Daniel and Heiko.
Geoff D.

Yes, just remove the “.zip” at the end of the filename.