Just purchased Cubase Elements 11 today and I have had a nightmare PLS HELP

I’m hoping someone can shed a little light on the situation.

Here’s what happened…

First, I purchased Cubase Elements 11 directly from the Steinberg website.
Then I received my download codes and was instructed to get the Steinberg download assistant and elicenser (the newest version, as was made abundantly clear by everyone and their mums in forums), which I did.
After I had installed both the download assistant and the elicenser I opened up the assistant and put in my download code for Cubase 11 Elements and it showed up in the redeemed section.

It then asked me if I wanted to activate my products.
I said yes to activation and the assistant opened up my elicenser.

However, there was a problem with my elicenser and it states that it would like to do some maintenance to sort any issues.
I accepted the maintenance.
It begins to carry out maintenance and after about 5 seconds it tells me that my ‘soft-elicenser’ is deactivated and I need to get in touch with my software vendor.

I looked online for about 3 hours for a solution and it feels as though I have tried everything.
First, I made sure that I had the newest version of the elicenser, then I tried running the elicenser as an administrator straight from the containing folder and finally I tried reinstalling everything to see if that would help.

I am now being told by the download assistant that it can’t open the elicenser and that I must have the newest version installed, which I do because the download assistant installed the elicenser itself when I reinstalled everything.

So I tried reinstalling the elicenser again, still no luck in getting the download assistant to launch the elicenser when I ask it to activate my products.

In other news, I noticed I could download Cubase 11 Elements through the assistant and did so.
After installing I tried to run the program, only to be told that there is no valid license.
I pressed the button to activate my product and cubase just terminates, leaving me wondering how could this have gone so wrong.

I also tried to register my elicenser with Steinberg but it just comes back saying that it has deprecated or something like that.

My main question is this: What in god’s name is a ‘soft-elicenser’ and how can it be deactivated despite me having never used anything from Steinberg before?

Can I get another soft-elicenser?

Is there anyone else who experienced so many issues whilst trying to set up their products and can I rely on the support team to help me fix this within the next week?

Failing all else how quickly can I get a refund?

I have university deadlines in the middle of may and have been forced to make the move from LPX to Cubase at the last minute, which I thought would be just fine about 6 hours ago.
Now I’m staring at my computer contemplating what failing a degree would be like.

TLDR; I can’t even.

Did you try skipping the maintenance?

I did and it still says ‘deactivated soft-elicense’.

I had a look online for how to generate a new elicense but I can’t seem to do it.

You have a MySteinberg account where you’ve registered the licenser?

Did you try opening up elicenser on its own and not through the DLA?

Then going to ‘Registration’ or ‘Actions’?

When I try to activate the elicenser it says ‘This elicenser is deprecated’.

When I run the elicenser on it’s own it still says that my soft-elicenser is deactivated.

Yeah I have no idea,

Are you not able to get to ‘Registration’ in the elicenser?

Yes, that links me to the steinberg webiste where it tells me that me elicenser is deprecated.

No clue what deprecated means.

According to the dictionary it means to express dissaproval of.
I don’t know why steinberg dissaproves of my elicenser.

1 Like

Here’s a Steinberg support page explaining the procedure. There’s a link in the text to download the latest version, probably a later version than the one that got installed with Cubase. Try it.


There’s a description of the activation process here, too.

If you are still having trouble, be sure you are registered here:


You must register your eLicenser software here. Copy and paste the code identifying the eLicenser from the eLisencer software into the text box on the registration page.

This can be confusing, putting it mildly. Not to mention they recently changed the procedure just to keep us old guys on our toes! .

i cannot use my activation codes because there are no soft-elicensers and I can’t afford a USB-elicenser.

I’ve tried everything I can to get a soft-elicenser but nothing is working.

I also can no longer open the forum on my PC.

It opens on my phone just fine so I know that the site isn’t down.

Responding vie email at the moment.

Kind of feels perosnal at this point aha

I have two copies of cubase 11, one LE, and one AI copy on two PC’s, both copies I had to “start a ticket”, which is an email, with my old codes and an explanation, and I was sent new codes.

I too thought I did something wrong when the second time, I had the same exact thing happen as you did. I am just getting warmed up to Cubase, it is a rather steep learning curve right from the get go.

IT may take 3-4 days before you get a response and new codes, but don’t fret, it’ll get sorted out. IT is a rather intimidating process that leaves even a well seasoned PC operator screaming.

I read an article recently, about how Steinburg was going to can the whole E-license deal for something better. That would be nice eh?

There isn’t anything wrong with my codes as far as I can tell.

The download assistant downloads and installs the eLCC, then it tells me that it isn’t installed.
I can however run the non-existent eLCC.
There are no licenses or soft-elicensers on my eLCC and I therefore cannot use my activation codes.

I read that running the eLCC as an admin from it’s containing folder will generate a soft-elicense but it doesn’t.
The eLCC helper deleted the broken soft-elicense that I had but didn’t create a new one.

If I went to a shoe shop, paid £85 for shoes and the clerk brought me the wrong shoe size, moved to Germany and went into a coma I would definitely stay away from that shoe shop.

Unfortunately avid won’t accept my card for some reason so I’m stuck trying to deal with this.

I thought Cubase Elements needed a USB E-Licenser to operate. Maybe I’m wrong or the situation has changed recently.

I have a similar problem, even worse! there were 10 kubays with a soft elixir for several years, then I downloaded 11 kubays and without opening it once, everything stopped working! 11 cubays and 10 cubays no longer work and require license activation. The elicenser is lit in red.And I don’t need to write that you need to make DEACTIVATION or you need to REGISTER an elicenser on my Steinberg - all this does not work!!!when registering, writes “this elixir is outdated” in the elicenser itself writes"contact the software vendor"this software elicenser is disabled and needs to be restored.I did everything and synchronization, and wrote to the support of Yamaha, everything is useless!!! the idea to upgrade for 100 euros immediately left me, as well as to deal with this product…My work tracks are still in the projects and I can’t open them anymore!I sent a report on the status of the elicenser, which is formed in the elicenser itself, and everything is useless!!

I’d note, that very very few people seem to have these problems.

Not saying you don’t have a legit problem, just try to remain calm and you might realize you are doing something wrong or user error, and then write your steps in point form.

1 Like
  1. through the asistent again I download 10 cubes2.I download the elicenser.3. I open the assistant, enter the access code, enter the activation code - it recognizes it but! a window pops up where it says “download the latest version of the license” and I just downloaded it from the Steinberg website…4.I go to the elicenser, I try to enter the activation code there, but the elicenser writes - deactivated softelicenser, disabled , since it can not be confirmed, contact the software supplier"(I contacted them for three weeks with reports generated from the elicenser and screenshots - it is useless), then I try to copy the serial number of the elicenser and register on my Steinberg-to which I write - "this elixir is outdated"I do deactivation - writes - "I enter the access code = writes in response - this software does not have any license - that is, it is empty.as a result, after downloading and installing 11 kubeisa, nothing works. elicenser empty deactivated and even 11 cubase trial I can not put

Uploading: Снимок экрана 2021-03-30 222244.png…

Okay I will try to make sense of what you are saying

What do you have registered in you MySteinberg account? are your elicenser and MySteinberg account linked?

the number of the software elicenser, which is highlighted in red font in the elicenser program and deactivated - on the site my steinberg, when reactivated, writes that this number is outdated…but there is still some elicenser-next to the numbers are written, and these numbers in the program elicenser do not appear anywhere and I can not do anything with them

Uploading: лицензер3.png… the second row of numbers elicenser is successfully registered on my steinberg, but they are not found anywhere in the elicenser program
if I understand correctly the second combination of numbers is not associated with the program elicenser…I did all the operations that are possible-the result is zero