Kensington Trackball issues

Hi all. I can’t get either of the top buttons to work in Cubase 11. All of the buttons on the trackball work in all of the other software on my computer except for Cubase. Any suggestions.


Are you on Windows or Mac? Which version? Do you have the latest driver (of the mouse, if there is any specific driver; and graphic card driver) installed, please?

Check the Kensington ‘TrackballWorks’ utility - you can have different profiles per application, it’s possible that you have one for Cubase 11 setup in error which has those buttons disabled.

Or it’s possible you have buttons assigned that Cubase doesn’t recognise - do you know what they’re set to currently? (That utility will inform you.)

I’ve tried assigning the buttons for several different keyword shortcuts, even several different actions none of them work in the profile that I created for Cubase, also all of the same mouse assignments work in ever other program on my computer.(in the All Applications profile) There is only one Cubase profile presently. Also, Thank you guys so much for helping me.

Windows, Kensington Tech support had me try several different versions including the most recent one. None of them work properly.

Question, Can Cubase 11 recognize all four buttons and all six variations of those buttons i.e. the top two and top bottom simultaneously clicked.

It’s not actually Cubase that recognizes the buttons, etc - the Kensington driver and software send the customized messages to Cubase.

Cubase thinks the user is doing it for all intents ad purposes.

So yes, it can recognize whatever the trackball sends


I know there is at least one Steinberg member successfully using exactly this trackball with Cubase 11 & 12 on Windows.

@Martin.Jirsak If that’s not me, add one more. I discovered the device at a studio- I think many engineers of a certain age use it

1 Like

I guess that depends on what you have the buttons set to, are you able to share how they’re mapped?

I only have the two button version, but if I set button 2 to shift, then when I click on events with Button 1 they are added to the selection as I would expect.

Also, make sure you’re grabbing the correct Cubase .exe in the Kensington application. Is it possible you have an older version of Cubase also installed and the profile is linked to that .exe in error?

By the way there’s a utility out there that replaces KensingtonWorks called X-Mouse Button Control. Among other things it enables chording for any combination of buttons. Been using it for more than a year, works quite well.


I’ve started using a trackball with Cubase 11.
All programmmed button combinations seem to work except the top left. I try to set it to Alt+P but it refuses to send the instruction to Cubase, although the keyboard Alt+P works fine. However, if I set the top left to just P Cubase recognises it - as it does when I press both top buttons together, so the issue appears to be with the software rather than the physical buttons.
The top right button I’ve set to Ctrl+Shift+P and it works with no problem.
I’m running KensingtonWorks v2.4.0 on Windows 10.

I think this doesn’t have to do with Cubase, just the Kensington device.

Can you post a screenshot of Trackballworks?

Many thanks for the replies. Here’s a screenshot of the setting that isn’t working for the top left button:

All other settings are working, including Alt+Ctrl+E for the two bottom buttons so it’s not a simple case of Alt not being recognised. I’ve tried other shortcuts for the top left button and they work, so the button itself seems OK.

Alexis - I’m not sure what configurations within Cubase might affect the problem. The SlimBlade generally works fine with Cubase 11, and the Alt+P keyboard shortcut works on the keyboard.

Do you have the latest version of Kensingtonworks installed? I found that I could reproduce the error, and then updated.

Then, it worked.

Hi Steve,

I’m on KensingtonWorks v2.4.0. The ‘About’ screen confirms that it’s up to date and the Kensington website confirms v2.4.0 (24 Apr 2022) to be the latest version for a SlimBlade Trackball in Windows.

What version have you updated to?

2.40 also. The only difference I can see is you’re on Windows 10, and I’m on Windows 11. (I tested in both Cubase Pro 11 and 12.)

But doesn’t seem likely to me that such a difference would be the cause of this issue. More likely might be corruption of the Kensingtonworks preferences, (Paste %AppData%\KensingtonWorks into the windows Run dialog)

Aside from that, maybe there’s another application that filters or reserves keystrokes, that has profiles per application?

Hi Steve,

Many thanks for your advice. I’ve tried uninstalling and installing a new download of v2.4.0 but no change. I also unplugged a keyboard that could be used as a MIDI controller in case that was causing an issue but, again, no change.

Strangely, I’ve noticed that if I press and hold the button designated Alt+P and then spin the Trackball I get zoom in/out in Cubase 11. Usually when I want to zoom I use Ctrl+spin. In case Alt and Ctrl were getting mixed up I tried changing the keystroke to Ctrl+P, but that correctly gives me the shortcut for the Pool.

Short of buying a pc that will run Windows 12 I’m currently out of ideas! I think I’ll have to live with doing Alt+P on the keyboard and think up an alternative use for the top left button… :thinking:

Thanks, again, Steve.

That’s unlikely. It does sound like there are competing processes trying to filter the mouse presses, or, your Kensington prefs are corrupted.

(edited for clarity)
Hide the Kensington prefs folder and restart.

Then check what happens if you configure the buttons the same as before.

Sorry. I ran %AppData%\KensingtonWorks but didn’t know that I had to hide the prefs folder and restart first.

I’ve searched the KensingtonWorks 2 folder and haven’t been able to find a prefs folder. Could you confirm it’s exact title and where it resides?