Kerning for lyrics with apostrophes

When entering lyrics, I’ve noticed that words with apostrophes within a single syllable (like “He’d” or “o’er”) result in very tight kerning. The apostrophe seems to get almost no space, and the syllable looks cramped - almost like a typo. Finale has always given me the same result.

By contrast, MS Word adds a slight padding for the apostrophe, which looks a lot more pleasing.

Any chance the apostrophe could be given a little more wiggle room?

Thanks,
Dan

Edit: this happens with Minion Pro, which is my preferred lyric font. But Academico looks much better. Hmm, built-in padding for apostrophes could present a problem, since different fonts seem to give different results. Or maybe it’s entirely within the font, and there’s no way to address it.

FWIW there are some unicodes codes for very small hard spaces (U+200A)
Here are some useful codes : http://jkorpela.fi/chars/spaces.html

Marc, this is exactly what I need. Thanks!!

Probably a dumb question, but… how do I enter these unicode characters? I can’t seem to manage it. I’ve used alt-0252 and such, but these don’t seem to work as expected.

Since you’re on windows I cannot help you but a simple search in your browser should show you :wink:

I did search carefully before asking… sorry. Still not sure. Lots of search results, but nothing makes sense to me. Hopefully someone here on Windows may be able to help.

Dan,

Call up the Character Map utility on W10. Click Advanced View tickbox at the bottom. You can then enter a Unicode codepoint.

Thanks Craig!

Dan,

apostrophes within a single syllable (like “He’d” or “o’er”)

instead of using the inch/typewriter apostrophes ’
why not use the ’ ?
to my eye they look more correct, but I might be mistaken…

He’d > He’d

o’er > o’er

Do they give you better spacing in the lyrics line?

My experience is that Dorico does curly speech marks and apostrophes by default, instead of the straight versions, for which I am eternally grateful.

I suspect the issue may be down the font kerning. I haven’t noticed any issue with the fonts I use.

I agree with Ben that it is probably an issue within the font. On the other hand, Minion is a highly professional (and costly) font family and I doubt that MS Word adds space on its own… Maybe Dorico can’t read out some of its kerning data?

After a quick test, I’d say that MS Word uses slightly too much space for the apostrophe, but it seems to be a more pleasing result than the slightly too squished setting found in InDesign, Pages and Dorico.

Other fonts give different results.

I’d say it’s probably a combination of the font metrics and how a particular type engine renders them. It’s possible that Dorico doesn’t have that much choice in the way that Qt sets type.

The “6 per em space” should be

Alt 2006

according to https://www.fileformat.info/info/unicode/char/2006/index.htm

Does that work?

Kerning is font-specific. Only curly apostrophes and quotes are typographically correct.
A very useful font tool for Windows users is Babelmap, available at http://www.babelstone.co.uk/Software/BabelMap.html
It is free (though donations are welcome). You can copy characters (or strings) in Babelmap and paste them into any other application.