Key Command for Mackie Reset

I get tired of having to turn my Platform M+ off and on, and then navigate to Studio Setup and reset the Mackie Control every time I open Cubase. I understand, though frustrating, that this is intentional Cubase behavior.

Is there a key command or macro I may have missed to reset the Mackie Control so I can simply map that to Metagrid?


What’s the issue? Why do you have to switch the device off and On, please?

I use an Icon Platform M+. No matter what I do, it is always in an unusable state when I open Cubase. The lights and faders are where they need to be, yet I cannot move a fader or interact with it at all until I switch it off and on, and then reset the Mackie protocol.

Don’t know if it is a hardware quirk or Cubase quirk. Probably hardware. Either way, I’d just like a simpler solution for resetting the Mackie protocol.


Do you have the latest Platform M+ firmware and driver installed, please? Does it help, if you would start the Platform application and reset the device here?

Are you on Mac (Intel/M1) or Windows, please?

Yes to the latest firmware and drivers installed. Unfortunately it’s always behaved this way. No, it does not help. No matter which order I do anything in, the process is always painstakingly the same. I am on Windows 11, and have been doing the same since Windows 10.


Does your computer go to sleep? Or does the USB port (or the Platform device) go to the sleep mode, somehow?

It does go to sleep, yes. I’ve changed the power settings so as to not allow “suspend USB activity on sleep” to no avail, however.