Key Commands link opens localhost:0 in browser

Today when I tried to open the key commands file, it takes me to ‘localhost:0’, instead of the actual location. I haven’t attempted to look at the file in a while so I have no idea when this started to happen. How do I resolve this?

It sounds like perhaps a firewall or other program on your computer is blocking the running of the Dorico Web Helper application that is part of the Dorico installation. This little application is a local web server that provides the service that serves the key commands web page. Check your firewall etc. to make sure that this application is not blocked.

I turned my firewall off with no effect.

If you look in the list of processes running on your computer, do you see ‘Dorico Web Helper’ among them? It should be running on a port like 58536 rather than port 0, as well.

No, I don’t see it among the processes.

Can you tell us a bit more about your system? Are you on Windows or Mac?

Windows 10 64-bit.

If you look in Task Manager after trying to invoke the Help > Key Commands menu item, do you see ‘Dorico Web Helper (32-bit)’ in the list of Background Processes? It should be listed there if it is being launched correctly when you invoke the command.

No I don’t see it there. The only process that appears is just the tab that opens in Chrome.

Could you try something for me? If you open a command prompt and type:

"C:\Program Files\Steinberg\Dorico\Dorico Web Helper.exe"

What does it output?

There’s no output in the command prompt, but it executes Dorico and takes me to the Steinberg Hub.

Were you careful to include the quotes at the start and the end of the command? If not, it would most likely have tried to run the Dorico executable instead.

Okay, with the quotes I’m being told that it is not recognized as a command, program or batch file.

If you open C:\Program Files\Steinberg\Dorico in Windows Explorer, do you see the “Dorico Web Helper” executable in that folder?

No. There’s a webhelp folder and keycommands JSON files but no executable.

Do you have any anti-virus software that might be “quarantining” files?

My next suggestion would be to repair your installation by going to http://steinberg.net/sda, downloading and running the Steinberg Download Assistant (SDA), then downloading the full installer for Dorico 1.1.10 and choose the “Repair installation” option (or do a full install if “repair” isn’t offered).

For some reason I can’t get into my anti-virus’ quarantined files, but the re-install appears to have solved the problem as I can now see the keycommands on localhost:49845, and the Dorico Web Helper executable is where it should be now. Thank you for your assistance, Ben and Daniel.

No worries - glad you got it sorted in the end. If the files disappear again I would investigate your anti-virus further to see if it’s being a little over-zealous.