Key edit plays wrong instrument

How do I get key edit to play the instrument that is selected on the key edit page? It only plays what is selected on the home page.
When I open key edit the instrument that plays on sequence play-back is the correct instrument. But when I use the keyboard in key edit, it only plays the instrument that is selected on the home page. For example, if I open strings for editing in the key edit, it will play back strings, but when I play the keyboard it will play the instrument selected on the home page, such as a trumpet.

How do I fix it so my keyboard plays the instrument selected in key edit?


Do you change the sound by using Program Change on the track?

If you Chase Events (Preferences > MIDI), you should hear the sound regarding the cursor position.

No, I have made no program changes. KEY EDIT does not play ANY instrument that I select. It only plays the instrument on the home page.

There is nothing inside the Key Editor where you can select a VSTi to play. The closest is that notes can be on different midi channels & thus play on different instruments in a Multi (like Halion or Kontakt) or a Program Change for a different preset.

Can you describe exactly what you are doing inside the Key Ed that you think should be changing the VSTi?

FYI for future use, the real name is Project Window not Home Page. Questions are easier to answer when we all use the same jargon. :wink:

Here’s a more careful description.

  1. When I select a group of instruments on the project window and then double click the selection, that takes me to the key edit page, as normal.
  2. If I click/select on a note on the key edit page with my mouse it will sound the instrument that is assigned to that note.
  3. But if I play from my keyboard it will only play the instrument that is selected on the project window.
  4. On my Cubase 3.6 version, my mouse AND keyboard would always play the instrument whose note was selected on the key edit page, no matter which instrument was selected on the project window. So I don’t know why my Cubase 9.5 can’t do the same thing.


Is Record enabled in the editor?

I’ll have a look. But first I must unistall cubase because nothing else is working properly. I’m uninstalling everything. Never really got going with this software.


Try to trash Cubase preferences too, please.