Key Editor issue — Please fix

Hello,

When opening several MIDI parts in the Key Editor with “Edit Active Part Only” turned off, it’s possible to switch from one part to another by clicking on the relevant note. However, lasso-selecting the same note (as opposed to clicking on it) doesn’t have the same result (the active part stays the same). This is especially annoying when working with lots of controller lane data which can quickly become confusing.

Thanks.

Hi there,

first of all: please take a note how to report a problem:

https://www.steinberg.net/forum/viewtopic.php?f=19&t=3400

Follow the guidelines please.

As well I can not reproduce it in anyway, everything is working here as expected.

Apologies and thanks. Here’s a more detailed run down:

  1. Create an empty project.
  2. Add two MIDI tracks.
  3. With the Pencil tool, create an empty MIDI part on each track (size doesn’t matter).
  4. With the Key Editor create two different notes, one in each of the parts.
  5. In the Project Window select both parts.
  6. In the Key Editor, make sure “Edit Active Part Only” is OFF.
  7. Click on each of the two notes and the edited MIDI part changes, as expected.
  8. However, lasso-select the note which is in the inactive part, and the part doesn’t change.

I understand this behavior is advantageous when moving lots of note data around, but when just switching from one part to another it can get annoying to have to pin-point click (especially when the notes are small). Most often I’m switching parts just to edit the associated controller lanes, and therefore the Key Editor is quite zoomed out and notes are difficult to click on.

IMHO when lasso-selecting a note (or notes) which all belong to a different part than the active one, the active part should change, without having any effect on the current Edit Active Part mode. It seems to me to be the expected behavior from a UI standpoint and I therefore concluded it was a bug. Strong word maybe, “quirk” might be more suitable :slight_smile:

Hi there,

I have followed your step by step guide and can not reproduce it all.

Using the “Object selection” tool works as expected and nothing strange happens.
All notes are selected in both events.

Which version of Cubase exactly please on which operating system?

Hi,

I didn’t say notes weren’t selected in both parts, I was referring to being able to switch between parts by both clicking and lasso-selecting. Please read the two paragraphs following the step-by-step list carefully.

My system & version are in my signature.

Thanks.

Hi there,


The editors will only switch between the parts if you click on a note.
If you use the selection tool, you will have to press additionally “shift” and then click on a note in order to switch
between the parts.

Cheers,

Marcus

It seems to me that you’ve just eloquently restated the issue I was reporting in the first place…

Would that then not be a Feature Request?

Yep,

that would be an FR, the behavior is normal and by design.


Cheers,

Marcus

OK, FR then :slight_smile:

Thanks.

I just use Key shortcut “n” for Edit/Next part to cycle through the parts in the edit window…
Problem solved?

Partly. I use that as well, would’ve been really painful if that key command didn’t exist. But when you have a complex orchestration, just lassoing what’s in front of you is better than cycling through parts IMHO.

Agreed!
Would be nice to have this behaviour as an option, yes indeed it would save some time when working with string arrangements eg.