Keyboard not connecting

Struggling on the basics I’m afraid.

I have a Samson Carbon 49 keyboard I’m trying to connect to cubase 7.

I’ve followed the instructions here:
https://www.steinberg.net/forum/viewtopic.php?p=133303

But I still don’t get a sound/register of a note being pressed.

I think my cables are OK as the keyboard does play if I load up MIDI-OX - a separate shareware programme that I used to test it on.

I can’t understand why it seems to get it in the (much) simpler programme but I can’t get it to work in Cubase.

Anyone any experiences with this particular keyboard or this problem in general?

Thanks

Frustrated that I haven’t been able to sort this yet.
I’ve had Cubase for over a week now and haven’t been able to sort out the most basic setup issue.
Do Steinberg techies monitor this forum, or should I chase professional support through other channels?
Thanks

I don’t see your name or connection description in that other thread, and without detailed information about your signal chain and MIDI components no one, including Steinberg, can offer much help. In any case, a suitable MIDI interface instead of USB cables etc. is always a good first step in the right direction.

The instructions in the other post are for recording and looping back MIDI to a Roland keyboard that produces sound. The Carbon is only a controller and doesn’t produce sound. Just want to make sure that point is clear.

We don’t even know if you’re on Windows or Mac, but…

  1. Plug in the Carbon.
  2. Start a Cubase project.
  3. Create and instrument track with the instrument of your choice (note: not to be confused with a MIDI track).
  4. Make sure input routing is set to All MIDI Inputs.
  5. The output routing should already be set to the instrument when you created the instrument track.
  6. Hit the monitor button on the track and play. You should be hearing the instrument now.
  7. If not, put it in record mode and try to record (even if you’re not hearing sound). Is MIDI data being recorded? Do you see MIDI activity in the meter?

There are a finite number of observation points in the data path here. We just have to break into them and find out where the signal disappears.

The system - Windows 7 64bit
I’m not sure what the signal chain is I’m afraid.

Rather basically - I’ve got the Carbon 49 keyboard which I’m connecting via usb into the computer.

When I fire up Cubase it recognises that the keyboard is there is it gives me a ‘Samson Carbon 49’ option in the ‘input routing’ dropdown.

Unfortunately, selecting either that or ‘All MIDI inputs’ gives the same effect ie nothing.

I’ve tried the monitor button etc.

I can record MIDI via the qwerty computer keyboard - but there’s not a flicker from the Carbon. And it plays fine (but with substantial lag) from the free download MIDI-OX which I downloaded after reading another forum to test whether I was getting anything.

I don’t have a dedicated sound card in my computer. Will that have an effect?

In the Inspector (left side panel) of the instrument track you see the MIDI routing. You say the input is either the Carbon or All. Cool. And the output, if you created an instrument track, is the instrument you chose (e.g. Halion). The last variable is the MIDI channel, which is the little number just below the output. That needs to be set to the same channel the Carbon is outputing.

I think there’s an option to set the channel to Any. Otherwise, go back to MIDI OX and see what channel the Carbon is outputing (or change the Carbon to the channel shown in Cubase).

Using on-board sound shouldn’t prevent operation, but it will seriously hamper performance (latency, track count, etc.).

I can’t see the midi channel - which you describe as the little number just below the output.
I’ve taken a screen shot to show you what I’m seeing…
cubase-temp.jpg
I really appreciate you guys taking the time to steer me through this!

Well, that sure looks correct!

I just checked the manual. MIDI channel seems to only be shown on MIDI tracks, not instrument tracks. Sorry for the misdirect.

So, in the screen shot you don’t see the blue-ish channel meter go up at all? Or the MIDI event indicator at the top of the Halion window? What happens if you hit the speaker (monitor) icon to the right of the record ready button?

Could you post a screen shot of MIDI-OX with you hitting middle C?

Most annoyingly, I’ve just fired it up again this morning as I was trying to show that the blue bar wasn’t doing anything
and it started working. I have no idea what I did differently. I didn’t change any options - no fiddling with cables etc.

However it works and it records.

(I noticed this after I did the screen shot of midi-ox - but suspect this is rather redundant now its working anyway!)

(I’ve just noticed when I quit MIDI-OX it breifly pops up a message saying “closing midi devices” - any chance this has anything to do with what the problem was?)
cubase-midi-ox.jpg

there was a couple of thread a while back stating this behaviour that in some cases some users had to use a third party software like midi ox to to be able to get the midi to start working in Cubase .

In these threads if I remember correctly all they had to do was open midi ox then close it and cubases midi responded the next time Cubase was started

john

I thought I’d lost all the (random) progress when I turned it off then on again to see if it would still work.

And it didn’t.

However, that pattern you describe…

  1. boot computer
  2. turn on midi-ox and get the keyboard to play on that
  3. close down midi-ox
  4. open up cubase

does work.

Doesn’t seem to work if cubase is on during the midi-ox on/off thing.

This happens randomly to us. Closing Cubase seems to fix it although I frankly do not know why it happens! check that you have MIDI in led lighting up on the transport bar when you press a key. The rest as the other contributors have suggested. :smiley: