Keyboard Shortcut chord symbols in German version?

Congratulations to Dorico-Team: 1.1 is an really exciting step with great improvements!!

I’ve got a small bug in the german version: After installation and complete restart of the computer Dorico is running fine.
But it is not possible for me in the german version to use the keyboard shortcut “Shift Q” to input chord symbols. It is possible to input them with mouse click on the button on the right and using the menu, but not with the keyboard shortcut. I tried to enter the shortcut in the preferences, but without success.

The shortcut is not shown in the menu and is not shown in the popover on the right button in the “Write Mode”. In your (english) videos I see this …

Is there a bug in the keykommands-file?

See attached screenshots for documentation of the behaviour.
Thanks a lot for having a look at this issue.
Dorico 1_1_Keyboard shortcuts_Chord_DE.jpg
Dorico 1_1_Keyboard shortcuts_Chord_DE2.jpg

https://www.steinberg.net/forums/viewtopic.php?p=648208#p648208

That’s it!! Thank you very much.

For information to other german users: “my” own key command overrides come from the bug in german version 1.0.30. I had no other overrides!
Months ago we solved a problem with a key command file from Ben from Steinberg (see topic https://www.steinberg.net/forums/viewtopic.php?f=246&t=113823). This was the reason for this behavior!

Looks like when I copied the command file from Ben mentioned above, I copied it into the Program Files folder, not the Application Data folder as recommend. For some reason, the 1.1 upgrade did not replace the keycommands_de.json in Program Files\Steinberg\Dorico, so I’m stuck with the 1.0.30 version. Can somebody send my an updated keycommands_de.json (from Program Files, not Application Data) for 1.1?

Thanks!

Hello!
I run Dorico with English language (on a German Windows 7 PC) with a German keyboard. After updating to version 1.1, some key commands didn’t word e. g. “Shift+Q” for inputting chord symbols and “Shift+Alt+X” for inputting system text (these key commands also didn’t show up in the write menu). They worked after I reset the key commands to factory defaults although I didn’t make any overrides before nor did I ever install any key command file.

However, in engrave mode the key commands for moving the note spacing handles in larger increments “Alt+Ctrl+right arrow” and “Alt+Ctrl+left arrow” do not work. The key commands “Alt+right arrow” and “Alt+left arrow” do work, though.
Is this a bug due to the attached German keyboard or am I missing something here?

Here it is.
keycommands_de.json.zip (3.18 KB)

I’ve had a good look at the default German key commands file to compare it with the English one and these commands are defined identically in both. If you try changing the keyboard language to English in the top right-hand corner of the Key Commands page of Preferences, does that help?

Hello Daniel,
Thanks for your reply! Unfortunately, changing the keyboard language to English doesn’t help. I know that on windows computers sometimes these key commands are blocked by the intel hd graphics control (for changing the display orientation) but I deactivated these key commands in the hd graphics control. Is it possible to assign another key command for moving the handles by larger increments in Dorico?

Best regards,
Jens

Annoyingly not in the user interface, I don’t think. If you look at the keyCommands_de.json file in %APPDATA%\Steinberg\Dorico in a text editor you should find it relatively obvious what to change. The lines in question are:

					{
						"EventEdit.Nudge?Direction=Right&Amount=kALot" : [ "Ctrl+Alt+Right", "Ctrl+Alt+Num+Right" ]
					},
					
					{
						"EventEdit.Nudge?Direction=Left&Amount=kALot" : [ "Ctrl+Alt+Left", "Ctrl+Alt+Num+Left" ]
					},

Thanks, Daniel, now Shift-Q also works for me!

Jürgen