keymapping woes


#1 - i’ve just started having some strange problems w/keymapped shortcuts. i’m still pretty new to cubase, so i don’t know if it’s something i’ve done inadvertently, or if these problems are the result of my recent upgrade to 8.0.30.

i’d mapped ctrl-shift-L to the ‘midi - legato’ function. it’s been working fine since i made the mapping (i.e. a couple of weeks). now, all of a sudden, when i type ctrl-shift-L my mouse pointer over the midi note is replaced with a loudspeaker icon and the note isn’t changed at all. in fact, if i type ctrl-shift alone, my mouse pointer changes to the speaker icon. i checked my keymap preferences and ctrl-shift-L is still mapped to ‘midi - legato’, but nothing happens.

i then remapped the legato function to ctrl-alt-L. now if i type ctrl-alt (before i get to type the ‘L’), the cursor changes to a pencil (draw mode) and ctrl-alt-L still doesn’t do legato. if i type alt-ctrl (i.e., press the alt key and hold it before pressing the ctrl key), the MIX editor toggles the ‘q-link’ button off/on, and the note STILL isn’t stretched. if i hold down the alt key before i press ctrl, it also toggles the mix editor’s ‘sus’ (suspend all channel links) button. and all this is while i am still in the midi editor and the midi editor still has focus (i.e., the mix editor is behind the midi editor).

i’ve tried other mappings, still can’t get it to work. i’ve tried quitting cubase and restarting, it doesn’t help. i’ve read through the manual section on keymapping and also the section on tools (i thought the loudspeaker icon might mean i’d invoked some sort of scrub function), i can’t find anything helpful.

does anyone have any ideas as to what happened ? …and how i can fix it ?

#2 - one more issue. i assigned ctrl-alt-right_arrow to be ‘nudge +1 frame’ and ctrl-alt-left_arrow to ‘nudge -1 frame’. however, when i use these key combinations in the editor, the events aren’t moved at all. instead, the cursor is moved. it seems to me this is a bug, but… am i just not interpreting the command correctly ?

thanks !


Did you update something in the mean time (like system, or any driver…)? There is lots of modifiers in Cubase. Once. You hold Alt, you often get another tool (for example Pencil, what you described). Also the Volume tool is linked with some modifier (Shift, if I’m right). So it could somehow explain it. The question is, why Cubase accept only the modifier, and doesn’t trigger the key.

Are you using Virtual Keybord in the Transport Panel? If yes, switch it Off, this block KeyCommands.

no, nothing. i only updated to version 8.0.30.

is there any way i can disable that ?

no i am not.

Yes: Preferences >Editing > MIDI Modifiers > Select Tool

But I would recommend to try to find the core of the issue. Modifiers are very powerful in Cubase.