Keys F17-19 don't work as shorcuts on mac

Hello

I have a Mac Spanish layout keyboard which has function keys up to F19. The keyboard model is a Matias keyboard, and I love it because it’s very similar to the Apple Keyboard, but much more reliable (I’ve had 3 and the 3 stopped working after 2 years). These fn keys are very handy, because they are located above the keypad, so I wanted to use them for the main articulations (accent, staccato, tenuto, staccato tenuto). I can assign them in the keyboard shortcuts page, so they work and are recognised. However, any key past the F16 is not recognised when I actually want to execute the action.


I would be grateful if these could be made to work, although I’m aware that this might be related to QT and not to Dorico, and that I might be the only user in this forum having such a keyboard.

If the keyboard has a key labelled “fn” (usually under the F13 key), try holding that down and then press one of the F16 to F19 keys (then release both, of course).
You might also like to look at the Keyboard preferences in System Preferences. There is a checkbox relating to how function keys behave. The screen shot I have provided is from OS X 10.13.6 (High Sierra). It might look different in other System versions.

Thank you for your reply, @stevenjones01 . This didn’t solve the issue. I’ve had configured the keyboard to use the F keys as function keys. Neither pressing “fn” and the key nor changing that checkbox alters this behaviour, which should work anyway with my current settings:

FWIW, the F16 -F19 keys work for me on a standard Apple wired keyboard.

F16 works for me, it’s just F17-19 that don’t. I can assign them, but then I can’t use them. In your screenshot you show a F16 shortcut. Does F17 work as well?

I have just now tried assigning the F16 to F19 keys and, like you, I can assign them but pressing F17 to F19 does not result in any action. I am using a standard Apple slimline aluminium keyboard, model A1243. This is indeed puzzling behaviour.

1 Like

Ah: you’re right: Only F16 works. Sorry.

1 Like

Thank you, @stevenjones01 and @benwiggy for testing it in your keyboards.

Even stranger - on my keyboard, when I press F18 it behaves as if it is the “A” key, both by itself and in combination with shift, command, and shift-command. Similarly, pressing F19 behaves like the “B” key, also in combinations. For example, in Write mode, shift-F18 will create a rehearsal mark (normally shift-A) if I have a barline selected, and shift-F19 brings up the bars and barlines popover (normally shift-B). Command-F18 selects everything (usually invoked by command-A), command-shift-F18 selects more (same as command-shift-A) Of course, some actions will only happen if I have selected something and/or am in a particular mode (Write mode, for example) - I do know that some key commands will only work in one mode, or have a different behaviour in another mode.

This behaviour is only in Dorico, and does not manifest itself in other applications.

All I can think of is that the keys are being incorrectly recognised either by Dorico, the operating system, or the two interacting. When a key is pressed, it generates a keycode which is then assigned in software to a character, an action, etc. (I think I have got the concept correct). Maybe there is something about the keycodes for F18 and F19 that is somehow similar to those for A and B. Maybe those keypresses are falling through “cracks” in the code and ending up doing something that was not intended. When I tried to teach myself AppleSoft BASIC many, many years ago, one of my most common mistakes was omitting the Return command at the end of a subroutine. Instead of returning to the main body of code and picking up where it left off before jumping to the subroutine, the program would then “fall” through to the next instructions stored in memory, which could be anything at all.

Who knows what the cause is? I certainly don’t.

I can confirm this behaviour too! I’ve launched Sibelius 7.5 (for the first time in ages) because is the only QT app that comes to my mind I have installed, and there the F18 key does work as intended.

There’s definitely something weird going on.
FWIW, the Notation Express Stream Deck profiles use Cmd+F17-19, Opt+F17-19 and Cmd+Opt-F17-19 successfully, though I note that Cmd-Opt-F19 seems to be interpreted as Cmd-Opt-B in Write mode.

I have a note from developing the shortcut set that F17-19 don’t work by themselves, and nor do they work in conjunction with Shift-Opt.

A little off-topic, but related by way of being involved with keypresses:
I have discovered, quite accidentally, that if I hold down the Command key while double-clicking a Dorico document (to launch Dorico and then open the document) Dorico SE launches. Similarly, holding down the Option key causes Dorico Elements to launch. I assume that this a deliberate design choice to facilitate testing by the development team (and others?).

It is. This has come out several times in the forum. It’s a nice feature if you need to collaborate or help someone with another version of Dorico, to see what they can do or how the interface is laid out.