Keyswitch to cancel harmonics

Has the problem with natural not cancelling harmonics been looked at?

as in: https://www.steinberg.net/forums/viewtopic.php?t=106432

I have finally been able to setup the Garritan KS Harp to play harmonics (yay!), but they won’t cancel with the correct keyswitch (boo!). I just want to make sure I am not doing something wrong.

Try adding an explicit “nat.” playing technique.

I should’ve said that I did try that already, to no avail. If 16 is the switch for harmonics, then 12 should be the cancellation, I think … I’ll try a couple more combinations …

I can confirm that using Nat. does indeed work. I must have mis-typed something when I first tried it.

As it is a third party, I can’t expect perfection, but I wonder if this is a permanent situation.

Thanks again!

No, this shouldn’t be permanent - hopefully it’s something that we can sort out when we improve playing techniques in the future.

Thanks Paul!

One more thing, now that I have gotten it to work, using the transpose box in expression map and setting it to 12 in order to have standard notation for the harmonics (although writing them at pitch is acceptable as long as it is advertised in the part), doesn’t seem to work for me when there are articulations on the notes with harmonics. No biggie, but I though it should be reported.

If you open up the piano roll display in the Play window, you get a lane that shows what techniques are being sent to the player. Knowing that might solve the problem.

Since “exclusive groups” etc., are not working yet, you may need to define a separate entries in the expression map for combinations like “harmonics+staccato”, etc. Try searching some of Brian Roland’s posts for clues - though he wasn’t writing about the Garritan libraries specifically.

Thanks for the info. I will look it up.
The funny thing about the accents and harmonics is that it that the accented note still plays a harmonic (and shows the harmonic KS being resent for that note on the roll) but it puts it back in the non-transposed octave. If I put the transposition back to zero, the accent has no effect. Weird …