Komplet kontrol no kontrol on cubase 12

Thanks @Arnaud88 ! Your help has been amazing!
Is there a button (or combination of buttons) on an MCU surface (or on KK) to switch QC pages?.. Currently I switch pages from the rack with the mouse as you suggested

Danix78 and not the possibility of being able to configure buttons to change QC pages unfortunately. True, that would be very handy. Maybe in future Cubase updates… :thinking:

Thanks @Arnaud88
while you were answering me I published another post with some more requests, here:

Thanks a lot Arnaud

I had some huge Problems to combine a Komplete Kontrol S 61 MK2 and a Komplete Kontrol M 32
in my gear (Cubase 12 Pro) Once the autofocus problem resolved according to your instructions
I can tape live riffs with both NI kontrollers.

Most useful advice especially since Cubase Pro 12 s migration to further integration of remote keyboards!!!

1 Like

A post was split to a new topic: NI Komplete Kontrol S88 MK2 weirdness

Hi, checked my script for CB12?

https://forums.steinberg.net/t/komplete-kontrol-s-series-mk2-custom-script/848132

This not an official one obviously, but it can help.

@Arnaud88 thank you so much for posting this solution. Unfortunately, the solution you recommended didn’t work for me.

The issue you’ve described is exactly the same with the issue I’m having with autofocus on Komplete Kontrol. I’ve been trying to solve this issue for months with no luck and I’m not sure what else I can try. People have recommended things like deactivating my antivirus, locating certain files and moving them to a different folder, and deleting and reinstalling Komplete Kontrol. Resetting the Remote Control Editor settings has just been added to the list of things that didn’t work.

Any ideas? I’d really appreciate some help here :frowning:

Sorry to hear you were not able to solve the issue. This method has worked for me as well.
Reaching for straws perhaps, but have you relocated your My Documents folder from the default location? Have you tried deleting the “Generic 8 cells” file located in “C:\Users\ [REPLACE] \Documents\VST XMLs\Native Instruments GmbH\Komplete Kontrol\5653544E694B4B6B6F6D706C65746520”?

@mlib thanks a lot for your reply.

What exactly do you mean by relocating my My Documents folder from the default location? Happy to try this because I don’t think I have.

I just had a look at this path that you shared, (C:\Users\ [REPLACE] \Documents\VST XMLs\Native Instruments GmbH\Komplete Kontrol\5653544E694B4B6B6F6D706C65746520) and I’m pretty sure that this folder didn’t even exist before I reset the remote editor to the default settings about an hour ago. There are no files in this folder currently, so I’m not entirely sure which file I need to delete.

What do you think I should do?

Thanks again

Sorry, I just realized it is now called just “Documents”.
In Windows you have the option of changing the storage location of some of the user folders such as Documents, Desktop, Downloads, etc. A few years back when I was trying to get to the bottom of this issue, it seemed to me that the issue arose after I had relocated the Documents folder from its default location on the system drive to a different drive. I’m not so sure anymore that this actually has any impact on the issue, but I haven’t had the guts to try it out.

image
Here you can see the Documents folder has been relocated to the D: drive from the default location on the system C: drive.
To get there, right click the folder, click Properties and choose Location tab.

@mlib I’ve never changed the Default location of my Documents folder. I found this same window that you posted in your screenshot ant it’s showing the right location. I even clicked on “Restore Default” but nothing changed.

Also, weird things are happening… a few hours ago the Komplete Kontrol folder didn’t exist in my Documents folder. Then it appeared but had no files in the path that you gave me. Now I went on it again and the Generi 8 Cells.XML file was there! I deleted it, restated the PC and Cubase, but the issue isn’t fixed.

When you restored the Remote Editor settings to the default settings, did anything displayed on the Remote Editor window change? All the values remain the same when I change mine. Also, I’m using a couple of other midi devices like a Monogram Creative Console. Do you think this have anything to do with my issue? I don’t understand why it was working fine in the past and now it won’t work. It must have something to do with a setting that I changed in the past, but I can’t figure out what it might have been.

Do you think reinstalling Cubase would help? I haven’t tried it yet because I don’t want to loose all my remote device settings, hotkeys, and Templates.

Do you have any other ideas? I don’t want to give up so easily :sweat_smile:

Yes, I believe it did. I don’t think the NIKB11 was shown in the first slot (as in your screenshot above).

You don’t have to. It’s easy to backup all your settings. See this:

When you load an instance of the KK plugin in Cubase, does clicking this button bring back the remote functionality?
image

Hm ok I guess if nothing else works, I’ll have to reinstall Cubase and try to backup all my settings.

Yes, clicking on the keyboard logo brings back the remote functionality. To quickly describe the issue with images:

  1. I open an empty project on Cubase and add a new instrument track with Komplete Kontrol loaded in it. This new instance of Komplete Kontrol connects to my hardware S88 automatically, the keyboard logo that you showed me lights up and my keyboard is showing the correct screen.

  2. I add another channel (for example an audio channel) switch the focus to this new channel by selecting it. Once this is done, the screen on my hardware S88 goes to the Midi screen, which seems like the right behaviour.

  3. I click back to my Komplete Kontrol track, bringing it back on focus. The hardware S88 keeps showing the midi screen like it was when I selected the audio track. I then go and open the plugin and click on the keyboard icon that you showed, which fixes the problem and makes my S88 connect to it correctly again.

This focus used to happen automatically when I selected the Komplete Kontrol channel in the past, but now it’s not. I’m suspecting that this might have something to do with me using multiple midi devices, but I don’t see why. It feels like my keyboard is not receiving any information from Cubase when I select a track and it only does when I click on the keyboard icon manually.

Could you post a screenshot of your MIDI Port Setup Page by going Studio > Studio Setup?

I just deleted all my remote devices (I had another 3 midi devices connected and configured), and the only one left is the Komplete Kontrol S-Series. Still not working :frowning:

I’m not sure if it will fix your issue, but the Komplete Kontrol DAW - 1 port should not be in “All MIDI”. Try and untick that checkbox.

@mlib I just tried removing Komplete Kontrol DAW - 1 from “All MIDI” and it didn’t work.

I’ve also just deleted Cubase after years of having it on my computer, and reinstalled it. That didn’t fix the issue either.

Any other suggestions?

Just to be clear, you were not able to remove it or you did remove it but it didn’t make a difference?

I’m sorry, that’s all I have. At this point, I would try NI support.

From the screenshot you posted, I see that you’re using KK 3.0. Note that there are a lot of complaints for this version, and some users even noted problems with getting the komplete instances right.
There is a discussion for the 3.0 version, I think that maybe you should participate in it, if of course the issue started with the 3.0 and you didn’t have it before. I know you’ve mentioned that the issue is there for months on your side, at the same time I see that you’re posting here after updating to 3.0, so maybe it’s worth a shot.

I literally just spent all day reinstalling Cubase, and also updating my OS to Windows 11 from Windows 10. None of these things worked.

Any other ideas?