Komplet kontrol no kontrol on cubase 12

@mlindeb I’ve never changed the Default location of my Documents folder. I found this same window that you posted in your screenshot ant it’s showing the right location. I even clicked on “Restore Default” but nothing changed.

Also, weird things are happening… a few hours ago the Komplete Kontrol folder didn’t exist in my Documents folder. Then it appeared but had no files in the path that you gave me. Now I went on it again and the Generi 8 Cells.XML file was there! I deleted it, restated the PC and Cubase, but the issue isn’t fixed.

When you restored the Remote Editor settings to the default settings, did anything displayed on the Remote Editor window change? All the values remain the same when I change mine. Also, I’m using a couple of other midi devices like a Monogram Creative Console. Do you think this have anything to do with my issue? I don’t understand why it was working fine in the past and now it won’t work. It must have something to do with a setting that I changed in the past, but I can’t figure out what it might have been.

Do you think reinstalling Cubase would help? I haven’t tried it yet because I don’t want to loose all my remote device settings, hotkeys, and Templates.

Do you have any other ideas? I don’t want to give up so easily :sweat_smile:

Yes, I believe it did. I don’t think the NIKB11 was shown in the first slot (as in your screenshot above).

You don’t have to. It’s easy to backup all your settings. See this:

When you load an instance of the KK plugin in Cubase, does clicking this button bring back the remote functionality?
image

Hm ok I guess if nothing else works, I’ll have to reinstall Cubase and try to backup all my settings.

Yes, clicking on the keyboard logo brings back the remote functionality. To quickly describe the issue with images:

  1. I open an empty project on Cubase and add a new instrument track with Komplete Kontrol loaded in it. This new instance of Komplete Kontrol connects to my hardware S88 automatically, the keyboard logo that you showed me lights up and my keyboard is showing the correct screen.

  2. I add another channel (for example an audio channel) switch the focus to this new channel by selecting it. Once this is done, the screen on my hardware S88 goes to the Midi screen, which seems like the right behaviour.

  3. I click back to my Komplete Kontrol track, bringing it back on focus. The hardware S88 keeps showing the midi screen like it was when I selected the audio track. I then go and open the plugin and click on the keyboard icon that you showed, which fixes the problem and makes my S88 connect to it correctly again.

This focus used to happen automatically when I selected the Komplete Kontrol channel in the past, but now it’s not. I’m suspecting that this might have something to do with me using multiple midi devices, but I don’t see why. It feels like my keyboard is not receiving any information from Cubase when I select a track and it only does when I click on the keyboard icon manually.

Could you post a screenshot of your MIDI Port Setup Page by going Studio > Studio Setup?

I just deleted all my remote devices (I had another 3 midi devices connected and configured), and the only one left is the Komplete Kontrol S-Series. Still not working :frowning:

I’m not sure if it will fix your issue, but the Komplete Kontrol DAW - 1 port should not be in “All MIDI”. Try and untick that checkbox.

@mlindeb I just tried removing Komplete Kontrol DAW - 1 from “All MIDI” and it didn’t work.

I’ve also just deleted Cubase after years of having it on my computer, and reinstalled it. That didn’t fix the issue either.

Any other suggestions?

Just to be clear, you were not able to remove it or you did remove it but it didn’t make a difference?

I’m sorry, that’s all I have. At this point, I would try NI support.

From the screenshot you posted, I see that you’re using KK 3.0. Note that there are a lot of complaints for this version, and some users even noted problems with getting the komplete instances right.
There is a discussion for the 3.0 version, I think that maybe you should participate in it, if of course the issue started with the 3.0 and you didn’t have it before. I know you’ve mentioned that the issue is there for months on your side, at the same time I see that you’re posting here after updating to 3.0, so maybe it’s worth a shot.

I literally just spent all day reinstalling Cubase, and also updating my OS to Windows 11 from Windows 10. None of these things worked.

Any other ideas?

@kravvito Look in the vsti rack to see if page 1 is selected in each KK instance and also check in the vsti rack settings that the “Remote focus for VST Instant Controls follows track selection”.

@Arnaud88 thanks a lot for your help. Once again, I read your comment and thought this must be it! Then I turned on my computer, opened Cubase, and realised that my settings are already configured the way you said.

It’s so weird that I’ve tried absolutely everything, including reinstalling Cubase, resetting all of Cubase settings, and even reinstalling Windows, butthe issue is still here. I’d really appreciate any other ideas :disappointed:

@Kravvito Have you always encountered this problem? what version of Cubase are you using? because I read in another forum that the Cubase Element, LE, AI versions were not compatible with kk’s autofocus…

I have a template with hundreds of tracks, you mean to tell me I have to go into each one of them and do this step? You’re kidding, right?

I just bought a S61 MK3 with Komplete Kontrol 3.0 on a new macbook pro M2 Max with Ventura. I’m running Cubase Pro 12 and my keyboard isn’t even having switching problems, it simply doesn’t work. In my template or in a blank session. I can even add a Komplete Kontrol track with a Native Instruments plugin and it doesn’t work. It works perfectly in Ableton and Studio One so it is a Cubase issue. This happened 2 years ago when I bought the S61 MK2. Steinberg, can you please fix this issue? We don’t like spending over $800 on a keyboard, only to find out, the majority of the features don’t work in Cubase.


@esimone00, Go to your Documents and follow this path: “Documents\VST XMLs\Native Instruments\Komplete Kontrol\5653544E694B4B6B6F6D706C65746520” and if there is the “Generic 8 cells” file, delete the file. Then create a new project but without using a template and create Komplete kontrol tracks.
Also make sure in the vsti rack settings that “Remote focus for VST instant controls follows track selection”. The autofocus should work.

@Arnaud88 Thanks for the response. I am not finding any documents/vst xml files. Both in my user files or system library. I’m on Mac venture. Any thoughts?

Also, even if I do find it, and delete it. I have a template with over 900 tracks, will it ever work with it? Or are you saying this will only work if I create a blank cubase session with new komplete kontrol tracks?

I had the same issue. I deleted the file mentioned above and that did nothing. I then did the “default configuration” thing described by @Arnaud88 at the top of this thread and that furred the issue for me.
After that all instances of KK works as intended, both in new and old projects.

@mlindeb, manually deleting the Generic 8 cells file through the “Documents” restores KK autofocus but only for new projects or for new tracks created in old broken kk projects. You are right to specify that the solution posted at the top corrects new project and old project and that is why I recommend this solution which is the best and which automatically also deletes the Generic 8 cells file.
That said, this file is not bad in itself, on the contrary, it is the backup of our QC VST configuration but it is not really necessary in the case of kk which is better at the control level. settings. In the case where we also want to benefit from personalized QC VSTs, we must not reset the “default configuration” but click on “Potentiometer” on the left and select from the menu, NIKB… to reassign it to the first cell from page 1 in remote control editor and click “Apply” at the top right.
@esimone00, I recommend you do as @mlindeb just said, everything is there. And there is no question of doing this on each track of your Template, just one is enough. It takes less than 10 seconds. And remember to save your Template after correction.

1 Like

Je viens d’avoir le même problème autofocus KompleteKontrol / Nuendo 13. Je viens de supprimer le dossier Generic 8 Cells, et tout refonctionne Meeeerci thanks!!!