Komplete A61 keyboard

Hello, I just connected my newly purchased Komplete A61 keyboard to Cubase 10 - everything works fine except can’t MIDIlearn (right click -> midi learn). Checked all the settings in Studio Setup, all looks good, updated all the firmware, all the latest updates and still nothing.

Did anyone had to deal with it? Any fixes? Thank you!

Hi,

Where exactly do you want to use MIDI Learn function? In some Remote Device or Quick Controls? Or in any plug-in (which plug-in)?

Thanks Martin, midi learn doesn’t work with plugins, any of them. None of the Cubase plugins, NI, Sugar Bytes. I tried the keyboard in both modes (A61 DAW and A61), nothing. Cubase sees the keyboard as I can play sounds but no MIDI learn.

The strange thing is that in DAW mode I can control play/record buttons, pretty much anything else but the 8 knobs that are in the middle (see the attached pic). They are just not responsive for some reason.

Hi,

Please read Setting Up Steinberg Cubase Artist/Pro or Nuendo for KOMPLETE KONTROL. I can’t see, the knobs would be supported. As far as I know, NI switched from the Mackie Control emulation to own protocol. Which doesn’t seem to be integrated with Cubase yet (this article looks like a confirmation to me; even though it’s a bit older now).

Thank you. Would be great to hear from Steinberg team regarding the A61 knobs not being supported. Yes I read the links you included but I think NI updated the series by now and it should support Cubase, in fact they even have the cheat sheet for Cubase. So I’m really at lost what’s going on.

Is your keyboard in midi mode?

Hippo

I think so. How do I check?

It will be in the manual of course
None of this stuff is a cubase 10 question but a native instruments one.

Hippo

Just looked up your manual on line

Using SHIFT + PLUG-IN (MIDI) accesses MIDI
mode that allows you to use the KOMPLETE KONTROL keyboard as a MIDI controller.

Hippo

Thanks Hippo, but I’ve tried it and nope. Not sure whether it’s something I’m missing in Cubase settings or NI issue (and NI are not help so far).

Why not download a free midi monitor and see what your keyboard is actually sending.?

Try https://www.snoize.com/MIDIMonitor/

Hippo

I have the Komplete Kontrol S61 with no issues at all.

I have set up the 8 knobs to control Quick Controls. Works really nice.

If you have your A61 setup properly in Studio Setup then I’m not sure what else it can be. Have you opened up Controller Editor? It’s available from Native Access.

Hi,
I have had the same problem and this is how I’configured and solved it. Just in case someone need it:

MODE 1: direct assignment from the vst plugin.

Turn on the ACTIVATE QUICK CONTROLS button in the Quick Controls section of the Cubase inspector.

You have to put the Komplete Kontrol Keyboard in MIDI PLUG-IN mode, pressing SHIFT (on the Komplete keyboard) + the corresponding key (even if the light of that button is not lit).
Then:
Right button on the vst knob/fader and select MIDI LEARN; then move the knob on the Komplete Kontrol controller.

MODE 2:
Put the Komplete keyboard in MIDI PLUG-IN mode.
Go to Studio / Studio setup / VST Quick Controls.
In MIDI Input choose: KOMPLETE KONTROL A61 MIDI.
Check the LEARN and PICK-UP boxes.
Move the Komplete knobs to assign (MIDI Channel 1 will be displayed in the Cubase window.)
Press OK (Apply does not turn on)
REPEAT THE SAME PROCEDURE ABOVE IN THE TRACK QUICK CONTROLS SECTION OF THE CUBASE STUDIO SETUP WINDOW.

Make sure that all the komplete knobs assigned to each of the lines remain, both in vst quick contr. And trackl quick contrl.

WITH THIS THE KNOBS OF THE KOMPLETE ALREADY HAVE BEEN ASSIGNED TO THE QUICK CONTROLS OF THE CUBASE INSPECTOR.

Then press the “L” in the QUICK CONTROLS section of the cubase inspector and assign the knobs of the vst plugin to those quick controls. Then turn off “L” from the inspector.

Cheers.