Komplete Audio 6 - Default Sample Rate

Hi guys ,

I posted this on the NI forum, but not had any replies, does anyone have any ideas?

Is there a way I can force my KA6 to default to 44.1KHz when Windows starts, at the moment is seems to default to 48KHz which causes the audio to play at the wrong sample rate, when I manualy change the sample rate to 44KHz it seems to randomly change back to 48.

I’m running Win 10 64-bit (Cubase 9 Pro @ 44.1KHz) with the latest drivers on everything, is there some setting I’m missing here, am I missing something obvious?

Kind regards,

George Wood

Your interface should have a control panel where you can set Sample Rate, Device and Buffer like the Yamaha Steinberg USB Driver does for the UR line. That’s what you should look for. The Yamaha USB is found in Windows Control Panel.

Thanks Hurmpie,

Yes it does, I have it set to run when Windows starts, it always defaults to 48KHz and I have to change it every time I restart.

Maybe a google search will help :slight_smile:

Thanks again,


Dunno why I didn’t think of this sooner…

Disabled all internal playback / record devices; also noticed Windows had the default Sample rate for the default sound device set to 48kHz, I guess this was overriding the control panel for the Komplete Audio 6, hopefully that’ll be the end of it :slight_smile:



yea i had same problem - just right click volume icon → playback devices → choose your speaker → properties → advanced → 2 channel 24 bit, 44100Hz (studio quality)

Yes xerix,
You’re rigth, and thank you!
I want to add some tipps for those who are using also other apllications, such as Adobe Creative Cloud for example (because it seems overriding the default 44.1 kHz rate with its base setting of 48 kHz).

  • Disbale “Autostart” of Adobe Creative Cloud and related services in the Taskmanager.
  • Each Adobe app using audio (Premiere, AE, ME, etc.) in preferences: change bitrate to 44.1 kHz
  • via right click volume icon, it’s also recommended to apply 44.1 kHz 24 bit to each of the audio in- and outputs, as well. It’s a bit of step by step action, but in the end for me that was it, and the Komplete Audio 6 Setup remains stable at 44.1 kHz :slight_smile: