Komplete Kontrol Issues in version 12 Pro

Just got Cubase Elements 12 w/ NI S61 Mk2 and iit wont work on W10 Pro - how does yours work?!

I have Cubase 12 pro and a s61 MK1 and everything is fine.

I had the same problem after upgrading from Cubase 11 Pro to 12 Pro. Komplete Kontrol was missing as were many other instruments. I found this fix on another website and it worked!!
On Windows just delete “C:\Users\YourName\AppData\Roaming\Steinberg\Cubase 12_64” folder and run Cubase 12 again. It will transfer your old settings.

Same here; after C12 Pro not recognizing my KKS49MK2, I deleted all Komplete Kontrol (prog and drivers) from Win apps and reinstalled with Native Access. Worked in my case. thx stripealipe.

I have NI Komplete 14, after loading Cubase, HUB no longer starts immediately but lasts up to a minute. It’s the same with Halion Sonic, mediaBay, and when you want to save presets. This was not the problem with previous versions of NI Komplete.

I have same problem, I’ve had the keyboard for an hour and already Cubase has spoilt the fun in a new yet consistent manner

Hmmm, I’m getting similar issues, Cubase 12 Pro, Kontrol S49 Mk2,

I load up an instance of Komplete Kontrol, hit the ‘browser’ button on the keyboard and load a sound. The screens momentarily flash the relevant screen for whatever synth patch I chose, but then they disappear and it goes back to ‘midi’ mode.

If I check the instant of Komplete Kontrol in Cubase and go to its preferences, I can see that under ‘controller’ it has un-ticked my keyboard. If I re-select it, the screens light up with the relevant info again.
If I then go and browse a different sound/synth, it loads, briefly flashes the screens with the new synth and then again drops back to ‘midi’ mode.

Obviously don’t wanna do this each and everytime. Did anyone get to the bottom of any of these problems and have anything I can maybe try?


Did you upgrade Komplete Kontrol to Version 3? It has quite a few issues. If so, try uninstalling and reinstall v. 2.9
You should check on the NI forums.

Hey and thanks for replying,

I actually found a solution thanks to @Arnaud88 on these forums. Just took a little digging…

But, I now have another problem which I guess I’ll post up elsewhere in this forum for neatness, but, in a nutshell…

Setup a Kontrol S49 MIDI Remote Map in Cubase, set the encoders to ‘relative signed’ and then set the encoders in the Komplete Kontrol standalone app to ‘relative’ too.
Map the encoders to QC1 to QC8. They now pickup QC on any VST and smoothly pickup and change values. But, go to an instance of Komplete Kontrol, the screens show you the relevant KK VST and its controls. Twiddle away, again nice and smooth pickup. Now, go back to a normal VST and twiddle away and you’ll find a lot of the time the transition back to QC causes jumps in values. The values do update and look correct on the MIDI page/screen of the keyboard but they jump when you start to turn an encoder. Weirdly not all the time but a lot of the time.

Annoying… will report back if I find an answer…

1 Like