Kontakt Output Routing to Dorico Mixer Input

New Dorico 5.1.21.2098 user here… finding and understanding correct routing of Kontakt 7.1.8 outputs is difficult.

Kontakt 7 has a flexible output configuration system. It’s possible to create many either mono or stereo outputs or combinations of each and route Kontakt-hosted instrument plugin outputs though these outputs. I haven’t yet found a similar way in Dorico to configure the Dorico mixer inputs and it’s taken me a while to figure out how Dorico is accepting Kontakt outputs.

Initially, I set up Kontakt to output a stereo output for each instrument, assuming that each of these stereo signals would appear at a single Dorico mixer input (which I assumed to be stereo inputs). For example, with four Kontakt-hosted instruments, Kontakt would provide four stereo outputs labeled Output 1/2, Output 3/4, Output 5/6, and Output 7/8, resulting in eight mono outputs grouped into four stereo outputs. Dorico then responded with four mixer inputs as expected,

However, when playing only instrument #1, both mixer channel #1 and channel #2 mixer meters showed stereo signals (two meter bars in each channel) . In addition, when the first instrument pan control (NOT the mixer pan control) was set to full left, only the channel #1 meter showed a stereo signal, and when the first instrument pan control was set to full right, only the channel #2 meter showed a stereo signal (or what I thought were stereo signals at the time).

When playing only instrument #2, the same happened as in the above paragraph except with mixer channels #3 and #4.

When playing only instrument #3 or #4, the Dorico mixer did not respond with a signal. (no meter response on any of the four mixer channels).

The above behavior led me to wonder if each Dorico mixer channel was only receiving a mono signal - that is, in my configuration, Dorico acted as if it received only stereo outputs labeled Output 1/2 and Output 3/4. In other words mixer channel #1 received only the instrument #1 left channel, mixer channel #2 received the instrument #1 right channel, mixer channel #3 received the instrument #2 left channel, and mixer channel #4 received the instrument #2 right channel. The outputs from instrument #3 and #4 were lost altogether.

I have tried the same tests with instruments from both Native Instruments and Chris Hein - same behavior.

It appears that the Dorico mixer will not accept stereo outputs from Kontakt 7 - hosted instruments, unless there is a way to modify the mixer behavior that I’m not yet aware of.

The solution I’ve settled on is to accept that I can’t use stereo outputs and then configure Kontakt and its hosted instruments for mono outputs only. As an example for the above configuration with four hosted instruments, I choose from the Kontakt Outputs panel,
Presets / Batch Configuration > Factory > Mono 4x,
to configure four mono outputs. I could then check each instrument output individually to insure that it’s mono output is set to the desired Kontakt output, but that should occur automatically.
Then, when playing each of the four instruments, a signal is seen in each corresponding mixer channel meter. Note that each meter shows two bars as though the input signal might be stereo - but of course the input signal to the mixer is not stereo.

Note that this behavior may not occur when using a “standalone” plugin (not Kontakt-hosted). I have verified this with Arturia plugins - stereo signals are passed from the Arturia plugin through the Dorico mixer.

I’d like to hear if others can verify and possibly explain the behavior I’ve described. Possibly someone can even explain how I am mistaken! :wink:

1 Like

Hi @David_Doerr and welcome to the community!

I hope I understand your question. [EDIT: now I see that your issue is about stereo vs mono output… If I misunderstood your question, sorry. I leave the below explanation as a basic Kontakt workflow, I edited it with a final example that shows the stereo outputs, but I will delete it in case it fills up unnecessary the thread and in case is totally wrong… :slight_smile: ]

I don’t have a technical answer.
What I would suggest is not to use Kontakt as multi. Load instead every instrument as single kontakt instance. With modern computer RAM and capabilities, the amount of resources for new instances of Kontakt are negligible (every Kontakt instance uses only 100mb circa) and you save the headache to configure the outputs… (Just my 2 cents.)

But I am sure that someone else has a more detailed answer to your particular question.


Anyway I made a simple example and attach some self explanatory visual guide. I think Dorico takes care half-automatically of the audio routing, if you set all the correct settings in the endpoint setup

From what I understand, Dorico mixer channels are stereo, if kontakt has a stereo output.:

test kontakt routing.dorico (992.9 KB)

  1. Setup the Kontakt multi, creating factory stereo channels first and assigning it to the instruments so as the midi channels:

  2. Edit the number of midi channels and the number of audio outputs based on the amount of instruments:

  1. Change the midi channels accordingly on each track:

  1. And you can see that the outputs are stereo:

1 Like

Thanks for your reply @Christian_R! I’ve attempted to create an explanatory reply to you with images and youtube video links, but I’m having more trouble using the forum than I’ve had using Dorico with Kontakt! Probably because this is my first time here…

In the last image you posted, shouldn’t we not see bars in both the Flute and Violin channel at the same time? Because those two instruments don’t play at the same time.

David,

If your difficulty is attaching images and the like, the following may help you understand what is happening.

1 Like

Well spotted :slight_smile: : before I took the last image, to show the stereo channels activity of both instruments at the same time, I edited the score a little bit and wrote music for them on every bar (just repeated the two single bars that you see in the previous image). It was just for the screenshot to have both instrument visualising the nice cyan level-lines. :wink:

1 Like

Hi David,

Rest assured that Dorico will receive stereo outputs from Kontakt properly. I just made a little test to make sure there’s nothing odd happening in the latest version.

A couple of suggestions:

  1. When you have loaded your instruments in Kontakt, use the batch function “clear output section and create one individual channel for each loaded instrument.” That will automatically connect and label each instrument in the Kontakt mixer.
  2. Don’t try to set any panning in the Kontakt instrument itself, that will get overridden by the Dorico mixer as soon as you hit play. Instead, open the Dorico mixer and click MIDI in the “show” line. You can set the panning there, and you’ll see that the Kontakt instrument panning responds immediately.

Here’s a quick video that just demonstrates that it’s working correctly.

1 Like

Thank your for your reply, @Chester.Jankowski.

I see that your demo is working correctly, and thank you for the panning tip. I have been using the Kontakt batch function to create stereo outputs.

I’ve followed all of the suggestions from Christian and you but I must have a blind spot as far as the root of my problem. Could you provide more details on how I can set my test up to work like yours? If you would be willing to attach a copy of your project, that would be very helpful. Alternatively, could you take a look at my project if I post it?

1 Like

You’re welcome, David; we’ll get it figured out. My project is attached, and I’ll be happy to take a look at yours. I’m using instruments from the Factory 2 library, so if you have the latest Kontakt 7, this will hopefully open for you.

Kontakt stereo demo - 2024-03-19.dorico (852.9 KB)

The order of operations to create the test was:

  1. New project; apply the silence playback template (to start from a blank slate), add the 4 players in Dorico
  2. Add a single Kontakt instance; add the 4 instruments; use the batch to set the outputs; assign a different MIDI channel to each instrument in Kontakt
  3. Back in Dorico, use the track inspector to assign the players to the Kontakt instance, setting the correct MIDI channels
  4. Write some notes; use the MIDI channels in the Dorico mixer to set panning*; verify that it’s working correctly

*I don’t usually do the panning using MIDI channels, I would normally leave the Kontakt instrument panned center and use an audio channel in the Dorico mixer.

Thanks @Christian_R and @Chester.Jankowski for providing Kontakt-Dorico demos to try out and compare to my own testing. I’ve updated my tests to use the same NI-provided instruments as you have used.

My own tests - more info below:
Kontakt Test A.dorico (1.9 MB)

Kontakt Test B.dorico (2.1 MB)

My system is a 2017 iMac running Ventura 13.6.5 with a Mackie DL16S interface/mixer.

I’ve also run tests on an Intel NUC PC with Windows 11 and a Mackie DL16S interface/mixer.

I’ve updated both systems with Dorico 5.6.30.118 and Kontakt 7.8.1.

Bottom line: My test as well as both of the demos you provided to me exhibit the same problem I initially described in my first post above when run on my iMac. However, all tests run correctly on the Windows PC.

I have run Kontakt in stand-alone mode on the iMac and observed the expected four stereo instrument signals in the DL16S mixer - In other words, Kontakt works as it should on the iMac in stand-alone mode.

Conclusion: I may have inadvertently changed a setting in Dorico since I began using it a few months ago, but I currently have no idea where to look! I may try re-installing Dorico - I’m not yet certain how to do a complete uninstall in order to delete any mistakes I’ve made setting it up. I welcome any advice or help!

Following is a rundown on the tests I’ve run and the results.

Test A: Kontakt has four NI instruments, each with a stereo output. I’ve added four additional channels to Dorico for a total of eight.

iMac Result:  
	Instrument #1 Left Output > Dorico Channel #1 Left and Right
	Instrument #1 Right Output > Dorico Channel #2 Left and Right
	Instrument #2 Left Output > Dorico Channel #3 Left and Right
	Instrument #2 Right Output > Dorico Channel #4 Left and Right
	Instrument #3 Left Output > Dorico Channel #5 Left and Right
	Instrument #3 Right Output > Dorico Channel #6 Left and Right
	Instrument #4 Left Output > Dorico Channel #7 Left and Right
	Instrument #4 Right Output > Dorico Channel #8 Left and Right
	(Each instrument left or right output is delivered to both left and right sides of the corresponding channel)
	
PC Result:  
	Instrument #1 Stereo Output > Dorico Channel #1 Stereo
	Instrument #2 Stereo Output > Dorico Channel #2 Stereo
	Instrument #3 Stereo Output > Dorico Channel #3 Stereo
	Instrument #4 Stereo Output > Dorico Channel #4 Stereo

Test B: Kontakt has four NI instruments each with a mono output

iMac Result:
	Instrument #1 Mono Output > Dorico Channel #1 Left and Right
	Instrument #2 Mono Output > Dorico Channel #2 Left and Right
	Instrument #3 Mono Output > Dorico Channel #3 Left and Right
	Instrument #4 Mono Output > Dorico Channel #4 Left and Right
	 (Each mono instrument output is delivered to both left and right sides of the corresponding Dorico channel)
	
PC Result:
	Instrument #1 Mono Output > Dorico Channel #1 Left
	Instrument #2 Mono Output > Dorico Channel #1 Right
	Instrument #3 Mono Output > Dorico Channel #2 Left
	Instrument #4 Mono Output > Dorico Channel #2 Right

Test A run on iMac: (Instruments have stereo output signals)

Test A run on PC: (Instruments have stereo output signals)

Test A Kontakt:

Test B run on iMac: (Instruments have mono output signals)

Test B run on PC: (Instruments have mono output signals)

Test B Kontakt:

Problem Solved! @Ulf provided me with instructions on how to do a fresh reinstall of Dorico including deleting any preferences I had set. Dorico and Kontakt now work together on my iMac as they should. The procedure took only around ten minutes. I’ve also done a similar test with Cubase and Kontakt and things are good there as well.

Link to Ulf’s help:

4 Likes