Kontakt problem SOLVED!

Hey guys!

Im currently working on a project and all was going great until i attempted to add another VST library via Kontakt. It opened up the instrument and library fine but i could not find the instrument channel to add midi notes. When i pressed the VST key in the DAW with said instrument via the kontakt window the libraru was fine and sound was indeed coming through and even indicated this via the volume track of the attempted newly VST but i still could not find the channel in my project to enter midi information. I then found a channel with another instrument that i had added earlier in the project and noticed not only did it have its own channel it was also being fed through the newly attempted vst channel…my brain hurts…i hope im making some kind of sense.
Any help would be fantastic guys.


Please attach a screenshot of the NI plug-in window. Then we will see, which channel is in use in the instrument.

Depending on this you will use the same channel in the MIDI Track.

If you add a new Instrument track, the MIDI Channel is always set to 1 by default.

When i attemprt to play that VST instrument (DAMAGE 2) it plays another vst instrument from another channel specificaly this VST (Evolution Devastator) in pic 2.

I know its probably an easy solution but i just cant figure it out. Apologies im still quite the beginner.

If you click the “I” icon next to the camera icon in kontakt you can view and set your midi channel for each kontakt instrument within the instance of the plug.

You can then set the track midi channel in the inspector just below where it says “All Midi Inputs” and there is a number and a weird tiny window icon.

Don’t apologize - Cubase midi routing is by far the most unintuitive and confusing of any DAW on the market. It needs a serious rework and it’s surprising it’s still in the state that it’s in.

1 Like

Thanks Jms i will have a look and see if it fix’s the situation :slight_smile:

So i figured it out using your input and it worked. Somehow the instrument i was trying to use wasnt routed up correctly and was routed to a different instrument and i didnt even realise it. Usualy Cubase auto routes it for me but i guess it couldnt be bothered today haha…weird!. I just matched up the midi channel with the midi instrument TaDa! back in busines!. Makes perfect sense now but dang it was rather confusing for a novice like myself lol thanks for your input JMS.