Korg midi port not present (Kronos) [Resolved]

Hey, guys.

I suspect this problem is at the driver level but am hoping others have had problems with the Korg USB midi driver and might offer suggestions.

After all the normal install / uninstall / etc. issues, the Kronos, connected via USB, does not appear in the midi ports list. Given that I’m on Windows 7 I followed the path of the 10 midi devices limit debugging and have uninstalled all unused devices (show non present devices / show hidden, delete all greyed out devices, reboot, sacrifice chickens, etc.), leaving only my UR44 and the Kronos.

If I connect via midi cables through the UR44 everything’s fine but I also want to use the standalone Kronos editor, for which they strongly advise USB (5 hours versus 5 minutes).

In device manager, the Kronos drivers report working properly. The icons are not greyed out and indicate properly that they’re in use. The Korg control panel app is set to both (32 / 64 / both) as I’m on a 64 box but I believe the Editor (a customized MidiQuest app) is 32.

I’m only trying to see it via USB in Cubase and the standalone Kronos Editor. Their vst plugin is 32 bit only and thus a non-starter.

It doesn’t appear that I’m hitting the 10 midi devices limit, everything reports healthy, and yet the Kronos still doesn’t show up in either Cubase or the editor.

Does anyone who’s fought these battles in Windows 7 / 64 have any insights you might offer? Would appreciate any ideas so that Cubase can see the synth via USB.


I finally have it working. I’ve put my findings on the Korg site but am also including them here for the benefit of anyone else who may come this way.

I’d downloaded the latest drivers, which was a dual 64/32 install program for 1.15.r23. That didn’t work no matter what, and I tried it on one 64 bit box and 2 32 bit ones.

I then remembered I had a previous version of the drivers from the Korg PadKontrol (there was midi driver flakiness back then, too). So I uninstalled the current version and installed the older one, 1.13.r6.

Partial joy. Midi Ox showed the Korg under output, but not under input. Rebooted, tried again, same results.

I then went into the config utility. It was set to 64 bit, which is appropriate since this is a 64 bit version of Windows. So, I flipped it to 32 bit and tried again. Started Midi Ox and there’s the Kronos in both input and output.

I then fired up the Kronos Editor and it was able to communicate with the Kronos, sync up and fetch the patches.

The fact that it wasn’t working properly in 64 bit mode and that there’s no 64 bit version of the Vst plugin is probably not a coincidence. Computers and communication have never been a strength of Korg.

In any event, if you arrive here with similar problems, you may find success with a) an older version of the driver and / or b) changing the config from 64 to 32 bit mode.

Hope this helps someone in the future.