Korg Nanokontrol 2 Track Problem

I had another Nanokontrol 2 problem back that I resolved with the help of this forum. To be honest, this problem could have also existed then, but I since I haven’t been able to really dig deeper into Cubase until recently, I might not have realized it.

I have Cubase 10 (although 9.5 is also responding this way) with Windows 10.

So, I have the device hooked up and it’s recognized by Cubase. The transport controls seem to work just find. However, the track controls only work on tracks 9-16. And if I have 17 tracks, the device works as if Track 9 is Track 1 and Track 17 is track 8. It’s like the device is ignoring Tracks 1-8 entirely.

How I would expect it to work is that by default, the track controls would work with tracks 1-8, and then move up using the track up arrow on the device, and down using the down arrow if the tracks are set for higher tracks. but as mentioned above, it’s acting as if 9+ are 1+, ignoring the first 8.

I still have Sonar, and the the tracks respond perfectly to the device in that application. I’m thinking maybe there’s a parameter in Cubase I need to adjust or something.

Any help is appreciated!

Are you using it in Mackie mode? If so, are there buttons for bank switching?

Or, how is it configured in Studio Setup?

I’m using it as a Mackie Control in Studio Setup. But I’m not aware of any bank switching buttons. There isn’t much else configure in Studio Setup, other than User Commands, which I haven’t touched, as there’s nothing in the NanoKontrol instructions saying that that section needs to have any entries.

They have a bunch of stuff on their website, check out the parameter guide.

Well, well, well. Yup, I figured it out. I’ll explain what caused the problem and the easy solution for the sake of future generations.

I’ll spare the specific details of why this occurred to me earlier today at work, but suffice it to say that I in addition to the NanoKontrol, I have an M-Audio Keystation49 that I often use as my keyboard controller. There isn’t much to it but it has a small transport section, which, when setup as a Mackie Controller in Cubase, works ok. I hooked it up a couple weeks back.

So today, I thought maybe - just maybe - the two Mackie Controls are bumping heads. The moment after I wrote the response to Steve above, I remembered that I was going to delete the Mackie Control for the M-Audio’s transport. And guess what? Yup, the NanoKontrol worked perfectly after the M-Audio transport was deleted.

So, sure, I’d like to keep the M-Audio Keystation’s transport if possible, and if anybody’s aware of how I can configure it so it peacefully coexists with the NanoKontrol, please chime in. I’ve worked most of my existence without a transport on my keyboard though, so if I have to ignore it, I’ll ignore it.

Sad that I lost a lot of time trying to figure it out. But if this post helps someone else, that’s a good compromise! :slight_smile:

how does the transport of the m-audio device talk to Cubase? Have you tried setting it up as a generic remote instead of MCU?

@ Jeff Irok

In your previous setup Cubase thinks that Nanokontol 2 is Mackie Control Extender for tracks 9 -16.

One simple solution for this problem:

  1. Switch Nanokontrol 2 in Pro Tools (HUI) mode as described in manual.

  2. In Cubase set your M-Audio Keystation49 as Mackie Control Remote Device and your Nanokontrol 2 as Mackie Baby HUI Remote Device and they both will work perfectly together without losing any feature.


Hi Steve - Yes, I tried configuring the nanKONTROL as a generic device, but it didn’t work. :frowning:

Thanks for the response, steinmel! I’m not certain I follow your first point. I reviewed the nanKONTROL directions and didn’t see anything about putting it into HUI mode. Maybe I’m missing something…? In any event, I set the nanKONTROL up as a Baby HUI and unfortunately, it didn’t work. But maybe it would if I knew that step you mentioned…

Hi Jeff,

to put nanoKONTROL2 in ProTools (HUI) mode:
1. Disconnect nanoKONTROL2 USB cable.
2. While pressing and holding down the SET MARKER and PLAY buttons, connect the USB cable from your computer to the nanoKONTROL2.

to switch nanoKONTROL2 back in Cubase (Mackie Control) mode:
1. Disconnect nanoKONTROL2 USB cable.
2. While pressing and holding down the SET MARKER and REW buttons, connect the USB cable from your computer to the nanoKONTROL2.

Thanks Steinmel - I didn’t notice the subtleties in the nanoKontrol directions regarding which buttons to push and for which DAWs! Anyway, I set the nanoKontrol to HUI per your directions and configured it to be a BabyHUI, and it did in fact allow me to switch control between multiple tracks while the KeyStation was hooked up like I wanted it to. Unfortunately however, the nanoKontrol lost some other functionality. Specifically, the ability to set markers, forward or rewind from marker to marker, and turn cycling on and off. Also, I moved the track control, the first 8 always stayed highlighted, making it look like I had control of only the first 8 tracks, although I actually had control of the next 8. This loss of functionality wasn’t related to the KeyStation though, as I deleted the KeyStation and the nanoKontrol still suffered from the same loss of functionality. I also set the nanoKontrol up as a Mackie HUI, and it functioned more or less as the BabyHUI did.

The help is much appreciated regardless of the outcome! :slight_smile:

Hi Jeff!

I’m sorry to hear that.

Here is my observations:

  1. Transport controls on nanoKontrol2 in Baby HUI mode works flawless, including cycle button.

  2. As you already correctly mentioned, with Track buttons you have full control of another/previous banks of 8 tracks, regardless visually Cubase bar stucks in tracks 1 - 8. Make sure that in Cubase Mackie Baby HUI Studio Setup Enable Auto Select box is ticked and when you move any fader on nanoKontrol2 that particular track is selected, and Cubase tracks/mixer follows accordingly.

  3. You are absolutely right about markers. Shame on me. I overlooked this because I use another controllers in Generic mode for markers and such tasks.

Although in such relatively simple device as nanoKontrol2 Mackie HUI and Mackie Baby HUI are acting pretty same, Baby HUI is preferred here because in HUI you have annoying constant pulsating MIDI activity in Cubase (some sort of active sensing).

Of course, you may try to follow what -steve- already says and put your M-Audio device in Generic Remote mode instead of Mackie Control mode. This is an excellent advice, especially because your M-Audio device has only a few functions to program in Cubase Generic Remote editor.

Kindest regards and sorry for my broken english. (I am from Croatia, we are better in soccer.) :slight_smile:

steinmel22 - You’ve been great as well as patient with me, and Steve as well earlier on!

For some reason, after I worked out some kinks with the nanoKontrol and found the anomalies with the Baby HUI mode, I mustn’t have tried putting the M-Audio back into HUI mode and seeing if things worked with the nanaKontrol in Mackie mode. But it occurred to me that I didn’t after I read your reiterating of Steve’s suggestion. So I went ahead, left the nanoKontrol in Mackie mode, put the M-Audio in HUI mode and put it in Mackie Baby HUI mode in Cubase, and everything appears to work as I want it to now…!

I haven’t responded lately because I’m still acclimating myself to Cubase. I had a version of Cubasis long, long ago (yes, Cubasis was made for PC before it was on the iPad!), maybe in 2003 or 2004. It was a light version of the Cubase version of the time, maybe the first Cubase 9 or Cubase X. I had a hard time acclimating then. I think I just got too used to Cakewalk, and then Sonar. But it seems that I’m still having the same problem with Cubase Pro all these years later. I’m determined to power through it, but I may be posting more topics (I’ll try not to spam though!) Thankfully all you folks in this forum have been very patient and helpful.

Many, many, many thanks! :slight_smile: