KORG nanokontrol2/cubase7

hi…i got a korg nanokontrol 2 from sweetwater…but it’s not working withmy cubase7…i have win7/64bit and cubase7.0.4…anybody can help?

Hi there, I have a NanoKontrol as well and am also using Cubase Artist 7. You need to go to Devices>Setup. In the top left corner you will see a little +. Click it and select Generic Remote. At the top you will see MIDI Input, select your NanoKontrol.

Check the Learn box on the right. Under the Control Name column at the top, double click and rename each of these, allocating one line for each fader, knob or button on the device (see hint below). Delete/add the necessary lines. Once you are done, go down through and click on a line, push/turn the corresponding knob/button on the NanoKontrol, and click on the next and repeat. You will watch Cubase memorize each MIDI channel of your NanoKontrol’s controls. Once you finish you will be ready to move to the bottom part and begin assigning commands for each control on your device.

Hint: as the NanoKontrol has multiple scenes these will have to be mapped separately. Thus each fader on your device will need to appear at the top four times, one for each scene. Remember when having Cubase learn these buttons, make sure the appropriate scene is selected on your NanoKontrol.

Sorry this sounds so confusing, just follow slowly and all will be well.

I found a different way to go about this that may work for you:

  1. hold down the Set and Rewind button at the same time as you plug the USB chord from the computer into the Nano Kontrol (this suggestion came from the directions that came with the nanoKONTROL)

  2. Go to Devices> Device Setup> Quick Controls and select nanoKONTROL2 for both the MIDI Input and Output

  3. Then remain in or go to Devices> Device Setup> and hit the + button in the upper left hand corner and pick Mackie Control from the scroll down list, then select nanoKONTROL as your MIDI in and out. Hit OK.

That worked for me. Good luck!

thx for ur help…holding down the Set & Rewind button did the jobbbbb…it s working finally :slight_smile:

I know this is an older topic but the suggestion (holding down the set & rewind button) worked for me too. Thanks.

Regards :sunglasses: