Korg NanoKontrol2 Issues

I just got a Nanokontrol2 and am having a lot of issues getting it to work. I just want to use it to control the expression, dynamics, etc of my spitfire libraries. I cannot get it to work at all. I can map it using QC, but then that fader is ties to that specific track AND when I move it, the cc data is not recorded

I have read endless posts on the forum, but still stuck.

I have spent the last 2 hours trying to figure it out. Any help would be appreciated.

If you want to record CC data on a midi track, just set the track’s input to include the Korg device, and use the korg editor to configure the CC sent be the faders. No need for QC.

QC is automation, not CCs

The issue now is that some of the faders are linked to QC and can’t figure out how to stop that. When I plug in my M-Audio Oxygen, all I have to do is click the command in the plugin (say Expression), click learn and move the fader on the keyboard. From then on it works. With the Korg that does not happen.

So disconnect the korg device from QCs.

How? Also, I have a keyboard plugged in besides the Korg. I want to be able to play the keyboard and at the same time move the Korg faders for expression. It’s ignoring the Korg (which I setup in the Korg App for the correct cc’s for the faders I use).

See Setting up All MIDI Inputs

and possibly this might be of interest, though it’s more advanced:

Also, you must set All MIDI Inputs as the midi input.



Studio > Studio Setup > Track Quick Controls. Make sure, the MIDI Input is not set to nanoKontrol neither All MIDI Inputs, please.

So, I removed the korgnano from the QC, but when I open say Spitfire Orchestra and right click on expression and click learn, when I move a fader, nothing happens. If I do the same thing with my oxygen 49, the expression is bound to the fader I move.

I used the korg editor and assigned the cc channels to each fader on the nano.

First, enter the CC mode of the Nanokontrol, and press and hold the SET key and CYCLE key to connect to the power supply. Also, the next time you enter Nanokontrol2, it will remember the mode Settings and you won’t have to press it again.

1 Like

Thanks I will try that.

Maybe I don’t understand how all this works. At the moment I am able to right click any controls in either spitfire or kontakt and click learn. I then move a control on the nanokontrol and it works. I have to do this for every track. I also have a keystation 88 connected and the mod wheel is fighting the nanokontrol. Even without touching it, it wants to keep moving the corresponding cc. What am I not understanding?

Is using the learn command the way to do this or is it to assign the cc values to the sliders and knobs and then use the defaults associated cc values from the plug-in? Am I making any sense?

Thanks again for all the help!