Korg nanokontrol2 pickup mode fader settings?

Hi there, i have just purchased the Korg nanoKontrol2 but ca’t seem to get the Pickup Mode for the faders working properly. It’s installed as a Mackie Control, have used the Korg Control Editor to set it to Cubase, have checked off the box in Cubase that says “Pick-up Mode”, but to no avail. My faders still jump when i switch banks after adjustments (i.e. Track 1 will “jump” after working on Track 9). Am i missing something? Thanks in advance.

Hi,

Where can you see the “Pick-up Mode” in the Mackie Control Device in Cubase? Could you send a screenshot, please? I cannot see the “Pick-up Mode” in the Mackie Control Device. I can see this in the Generic Remote, Quick Controls, but not Mackie Control

Hi Martin, cheers, it’s the Pick-Up Control in the VST Quick Controls. Doesn’t that pertain to the nanoKontrol2?
Screen Shot 2015-12-29 at 6.59.49 AM.png

Hi,

I just tried the Pick-Up Mode of Cubase Pro 8.5 on my system (also Mac), and it works as expected.

Could be, the Pick-Up Mode is not part of Cubase Elements/AI/LE. Could you please check the Generic Remote Device, if you could see the Flags in the upper part? Can you see the Pick-Up Mode as a flag here (be aware, there is not global Pick-Up Mode, as it is in the Quick Controls).

Hi Martin, yes, in the Generic Remote Device, there is a flag for Pick Up. I am also wondering if it’s not available in AI LE as well. I certainly don’t mind updating to Elements to gain this feature if it’s possible, but won’t be able to afford Pro for a while.

I’ve attached a screenshot of what my Mackie Control window looks like.

Many thanks.
Screen Shot 2015-12-29 at 7.24.18 PM.png

Hi,

I just realised, the i put is Slider/Knobs, but the Output is Ctls. The Outlut should also be Slider/Knobs. Or am I wrong?

The only option given for Output is CTRL

I see, I think, I got it.

I expect, the Quick Controls work to you in the Pick-Up Mode.

The Reason is, the knobs are using Quick Controls settings, with the Pick-Up Mode. I expect, the knobs are sending MIDI CC70-77. Am I right? This is the reason, why you are using Quick Controls, right?

The faders are sending Pitch Bend data on Channel 1-8. This is the standard for th Mackie Control, so if you want to Control the faders from your NanoKontrol2, it must sends this. But, the Mackie Control Device has no Pick-Up Mode.

Yes, Martin, you’re absolutely right, they are CC70-77. This makes complete sense. That being said, I began to play around with the parameters in the Generic Remote Device settings and was able to get the faders to work in Pickup Mode. Now, I just have to figure out how to map the transport area.

Martin, thank you very much for your time and expertise, my friend. It is greatly appreciated! :smiley: