Lag with clicking on events and channels on Mac.

Is anyone else noticing a slight lag when clicking on channels in the project window, clicking on events, and dragging and trimming-by-dragging audio events? It’s intermittent as to how long the lag is, oddly, for no reason other than time passing by (unless there’s something going on that I’m not aware of). Can anyone else echo this, or is it something weird going on here that I have no explanation for?

EDIT: It coincides with the GUI zoom, etc., being sluggish. This tells me that something is going on in the Mac that is only causing this issue for Cubase and not other DAWs on my system.

Yes, I am experiencing all of this as well. C9 isn’t as ‘snappy’ as previous versions–especially when doing any midi editing in the lower zone.

Agreed. This is getting maddening, the Mac GUI situation. I know I say it over and over again, but Pro Tools and Reaper on the exact same system are very snappy and fast GUI-wise, so the computer itself seems to be OK. There’s something that Cubase is letting interfere with it (and not all Mac users experience this issue).

I wrote Fabio and will hopefully be sending him data/info etc. to try to help nail whatever is going on. I would suggest others do the same, because any additional help would clearly be good for them.

was hoping this would fixed 9. Haven´t noticed any difference from 8.5 really, but i´ve just installed it so I haven’t done any real testing.

On windows 10 I also notice a lag when editing hitpoints in the lower zone sample editor. Its not as reesponsive as it was in 8.5.2 sample editor.

I’m finding it really bad.

Example -

Click drag to select some parts in the arrange page while the track is playing. Quite often the lassoo square which should give you an indication of the area you are selecting isn’t drawn at all - you just get the highlighted parts after you’ve released the mouse click.

Another issue I see when playing back a track, is that you cannot reliably select a tool from the palette in the arrange page using the right click mouse option - it takes a split second to open the palette up and then its slow highlighting the selected tool as you scroll through them. 4 out of 5 times you end up getting a tool you did not want to select.

Now here is what I’ve noticed - its far worse the bigger the arrange page.

If I have the arrange page filling the whole screen (Apple 30" Cinema) then the above happens all the time on a track. Cubase cannot keep up drawing the graphics properly.

If I resize the arrange page so its only filling half the screen, everything works much snappier.

So it would seem that there is an issue with Cubase’s graphics, because this should not be happening, even on an old computer - we’re not exactly talking cutting edge games graphics here!

All of this is happening to me as well. I even upgraded my gfx card just to see if it was on my end (I needed a new one anyway–old one was ancient). With new gfx card, the sluggishness and lasso problem still occur.

Maybe it has to do with large templates? When I create a new project with one midi track, everything is quick and smooth. But my working template has a bazillion midi tracks and slow-feeling.

Tell me how all of you having issues here have your monitors connected to your Macs and what type of monitors they are. Directly TB/DP? HDMI converter? Something else? Seems there could possibly be a correlation (it’s still on Steinberg to fix it since other DAWs work perfectly well GUI-wise, but it might help find out what the issue is).

Also: Anyone who is having an issue with this, PLEASE message Fabio and he’ll tell you how to report the issue directly. Be cool and helpful with him. The more people that do this the faster we can get a fix, hopefully!

Just a bump to get info from people who are experiencing this issue, namely: How are your monitors attached to your Mac, i.e. with HDMI converters or not?

I’m getting GUI lag to. I notice something when zooming in and out to see if I can narrow down the laggy GUI. Say you have 8 tracks of audio with plugins on a laggy project in birds eye view,start zooming in on the first track selected, your notice heavy lag while zooming vertically really bad.Select the last track and try zooming vertically once the track heights get to a certain height the lag is barley noticeable.I believe it’s like this cause of the other track info (waveforms) are out of the zoom view. So it seems the lag is related to the waveforms of cubase and plugins for some reason at least in my experience it is. Turn off show waveforms on a laggy project look how snappy zooming is and clicking on audio events and highlighting events,really snappy. Side note I never get lag or delay working on a all midi project Virtual Instruments that is.

Yes, it’s totally related to the audio waveforms. On my system it has nothing to do with plugins at all; only the audio waveforms (I tested with and without plugins in the entire sessions and there is no difference with graphics issue). There are other graphic issues with Mac, too, like little dropouts sometimes when you open and/or close certain windows, etc. The weird thing is that some people on Mac are not experiencing this (though clearly many are).

Would you mind weighing on this post: https://www.steinberg.net/forums/viewtopic.php?f=250&t=108500 ?

I want as many people as possible to post their specific issues and setups on that thread specifically, to consolidate some info for Steinberg so we can try to push/help them to correct this. From what I understand it was fine in version 7.5, then became broken in version 8.

Funny thing is that MOVING an event with audio waveform is sluggish as f*** but SLIPPING the audio waveform within the event is fine an without any lag

Yes, same here.

Please: https://www.steinberg.net/forums/viewtopic.php?f=250&t=108500

Any info on this? I have had this for awhile. Just upgraded to the fully pimped out 2017 iMac i7 and it is even worse. So frustrating to edit on.