Laggy Play head Video

I’ve tested this with a fresh install of Cubase 8 and 8.5 on a fresh install of Mountain Lion, Yosemite and El Capitan. Laggy. And it’s not the screen capture software running effecting things. Thats pretty much exactly how it looks without the screen capture running. CPU and HD minimal as you can see.

Anyone else?

https://youtu.be/cSnCXv4LrjA

I’d sure like to know why it’s so laggy. I also run Logic X with 60 plus tracks with no lag on the play head at all. Same system…same latency setting.

Is Cubase Pro 8.5 GUI that much more demanding than Logic X?

It seems that way at this point to me.

Probably not, but someone mentioned the cross platsform situation as a potential culprit.

Dont know, but I think it is safe to say that this is an general issue. Would be nice to hear something from a dev in order to see if this is something they plan to fix or not.

Thank you for your reply! Yes I’d like to know if there will be a fix for an improvement in GUI issues on the Mac platform. I cannot see moving to Cubase 9 without fixes to 8.5.

you could try some things like lowering the resolution and removing the timecode from your status bar. Not to as a solution but to see if it affects the performance.

Watch when my mouse hovers over the parameters in the Inspector on the left hand side. Horrible playhead lag.

https://youtu.be/a2zddmf1S58

Does this change if you make the window smaller?

When making the window smaller there is less distance for the play head to travel so it doesn’t look quite as noticeable but it is the same result yes. I guess the point is that it shouldn’t happen at all. I can run 60 plus tracks of instruments and audio tracks on Logic x and the play head is steady as a rock…even when zoomed out. Same hardware…same OS…same latency settings.

To do a 1:1 comparison make the window vertically smaller.

Can you link to a bug report on this?

Same lag a t one row height. I think it’s an interrupt conflict with mouse overs in the coding.

https://youtu.be/SqJ5Vd-LD2c

This sluggish behaviour is known to me on the Mac side since Cubase SX and it never got any better.
The bigger the monitor resolution the worse the zooming (for example 2560 x 1440).
PC on the other hand is blazingly fast compared to mac.
I hope that Steinberg has this on the “to do - high priority” list. :frowning: