Language change prevents usage


I am using Dorico 3.0 and I have 3 languages installed on my PC which I use. However only when English is on can I use Dorico commands, such as Ctrl +C, Ctrl +V , Add bars, the shift key in general, alt + etc. , etc. This prevents Dorico from being usable unless I have to revert back to English
which does costs time and hassle to frequently alt shift and languages as I also write in the meanwhile in two languages also within the score itself.

How do I solve this? if cannot be done, this should be treated… I will never pay for an upgrade when this feature should be rudimentary to the overall function of the software. In addition there’s still no good solution for tied notes in repeat endings. I have voiced this before, I like Dorico but you can’t possibly charge for a future upgrade that fixes this when this is indeed a bread and butter feature. Same goes for a “swing” tempo equation as in which to indicate the rhythm is swung (triplet) … and also text boxes containing comments or instructions cannot be copy pasted (why shouldn’t it be though? that limit has me stumped)

I’d understand if you’d ask payment for more orchestra libraries and such you’d come up with or a new super advanced Playblack algorithm A.I., but c’mon this is just unacceptable. I have invested plenty of $$ in Dorico 2 and then Dorico 3 PRO but I begin to regret my decision as both Sibelius can handily do what I said in previous paragraphs and also free stuff like Musescore… as it came to my understanding Dorico’s team developed Sibelius so I’d come with the impression that it’d do better :frowning:

Sorry if it came as a bit of a rant but please view it as a constructive criticism from user comment. I love Dorico for its GUI (I actually think Steinberg Products all have one of the Best GUI in the market which is what attracted me to it) and I think Daniel has been very understanding and supportive as much as he could but when such vital functions are still missing in version 3.0 it’s kinda sad actually when the team eventually (if ever) comes up with the fix for these problems users will have to pay more cash to get it through updating to v. 4.0 … seems not fair :frowning:

Thanks for your feedback, Chummy. To solve your issues with running in different languages, you should find that if you go to the Key Commands page of Preferences and set ‘Keyboard language’ to the specific language of your physical keyboard rather than leaving it on ‘Auto’, you’ll then have a consistent set of shortcuts regardless of which language your operating system is set to.

With regard to your more general complaint about things that you consider to be basic functionality which Dorico does not yet have, the whole notion of “basic functionality” is completely subjective, and completely dependent on the kind of work you are doing with the software. We certainly plan to add proper support for items tied into second and third endings and swing indicators, but in common with the way we approach all feature development for Dorico, we’ll only tackle these areas when we can give them the full attention they deserve. At least in the case of swing indicators it’s already very easily possible to produce a good result using the Metrico font.

Our aim is always to make each update compelling for as wide a range of customers as possible, but we are realistic about the fact that we cannot please all the people all of the time. I would always say to you that if you don’t find the features and fixes we have provided in a given update, you shouldn’t buy it. Hopefully the next one will be more useful to you.

Just specifically about your comment about “text boxes [that] cannot be copy pasted” - if you mean text frames, you can copy and paste frames to other pages or indeed the same page, if you want to duplicate a frame on a page. It’s just that the method is a bit different to Ctrl/Cmd-C and Ctrl/Cmd-V, and if you’re editing a master page, the only way to copy frames is to duplicate the whole page L-R or R-L.

To illustrate what Lillie is saying:

In this example, the text box has been selected, then pages 2 & 3 have been selected to receive the text box. And I believe the exact positioning is preserved in the copied text frames (which can be changed if desired).

Thanks for your answers guys^^^! The Language thing I did doesn’t work, now only 2 languages are affected by the change and can use be used as keyboard shortcuts but the third one (which I guess is also the OS) doesn’t work at all :frowning:(
and your solution and explanation is much appreciated as well Musicmaven!! works great.
still wish there would be a way to just pop that swing tempo equation anywhere I want in the score or just drag it onto the score
I tried googling "metrico font " as Daniel said but came up with nothing helpful … not sure what you meant there would appreciate more insight
stay safe

edit: I just re-tested with keyboard language mode “default” and then specified to “english” from the key commands menu
either way only 2 languages respond to key commands and the other one does not. My physical keyboard has 3 sets of letter symbols


thanks Pianoleo, I successfully installed Metrico font, do you know of any “map” that would tell me which symbols are assigned to each letter on my physical keyboard? I found only 2-3 of the symbols so far by trial and error… tried googling again to not avail, cause I wanna be efficient on this

This is available on the previous page I linked to:

Hi Chummy, the picture that Leo has posted is the only “documentation” I have for Metrico. If you can’t figure it out, just ask here or raise an issue in the repository and I’ll see how I can help you.

Hey Leo THAT IS GREAT, thank you so much, VERY helpful.

Still awaiting a solution that would not require me to switch back to English from my other language every time I wanna copy paste :frowning:
it’s a huge thorn in my workflow which slows me down quite a lot. Is there any hotfix coming for this soon?

@fk thanks mate, cheers

No, there’s no “hotfix” coming for this issue because we do not yet know what your issue is. Can you please be extremely specific about exactly what problem you are experiencing? You need to provide full details of your operating system version, the language settings you have, the keyboard layout you have, what settings in Dorico you are using, how you are changing things, etc.

okay sure, I am running Windows 10 OS , 64 bit system with Dorico Pro version 3.0
My problem is that I have 3 installed languages: English, Hebrew and Arabic. But for some reason all Dorico shortcuts including adding bars (shift B), copy / paste (Ctrl C , Ctrl V) and pretty much any other command will also work when the language is set to English. I tried applying the solution you advised beforehand quote:
“the Key Commands page of Preferences and set ‘Keyboard language’ to the specific language of your physical keyboard rather than leaving it on ‘Auto’”
but to no avail . Working with Dorico that way is extremely tedious and frustrating. Since I do add text comments in multiple languages and while working on Dorico I do switch between languages to also do other things in the meantime like searching google, Youtube, chatting with friends etc.
Which is why I constantly have to switch back and from to English just to use key commands and it’s hard…

Also regarding the tempo equation, is there away to write it down once in a metrico font and save it as a preset as to be available in any new Dorico project that I open up? that would be extremely helpful not having to re-type it any project and just select or drag it when it’s already ready for me.

Thanks Daniel

I’m not an expert on how international language support works on Windows, but when you’re using complex scripts like Hebrew and Arabic, isn’t it usually the case that the Input Method Editor provides a quick way to switch between Latin type and the more complex script, with a shortcut like Ctrl+Space?

Yeah, I use alt + shift in order to cycle between languages. The problem is that I always have to cycle back to English in order to have all key commands work (like: adding bars, copy/paste, moving notes, etc.) basically when not in ‘English’ mode the alt shift don’t work and this is actually a significant setback in my workflow. While constantly working with different languages having to switch back way more than necessary is inconvenient and highly time consuming… I hope you understand, as this is quite the issue for me :frowning:

I do understand. If you don’t want to change keyboard language, another option would be to define your own keyboard shortcuts for the functions you use most often that work in your chosen language, so that you don’t need to switch back to English each time. This will take some time to set up to begin with, but should save you time in the long run.