Laptop CD Reader/Writer not being recognised. 'No Device'

I’ve had WL Elements 9.5 for a while now.
As it’s holidays I have had time to work in WL Elements 9.5 again for a bit and during this time I found out about the Audio Montage CD window and also the CD Import window.

My Laptop CD/DVD Reader/Writer (TSSTcorp CDDVDW SU-208GB) is not being recognised by Audio Montage CD Window or the CD Import window.
They just show ‘No Device’ and when I refresh the list it still shows ‘No Device’ in the list.

When I use NCH Express Burn Disc Burning Software, my drive is recognised straight away.

Is there a way to help W L Elements 9.5.40 to see my CD/DVD Reader/Writer?

Please help.
Kind regards,

If a drive is not detected, that means the Gear ASPI driver is nor properly installed.

Here one can verify if a driver is properly installed:

Here you can execute the latest driver update:

Thank you for this. I’ll let you know as soon as I’ve tried these.
Kind regards,

I have used the GEARAspi driver checker and it has given me these details.
64bit GEARAspi driver set installation verifier
Press enter to start the verification process.

Verifying GEARAspi driver installation…
No Upperfilters value found in DVD/CD-ROM drives class
GEARAspiWDM service is not running.
Driver verification has Completed.

Drivers are not correctly installed. Error 3000000.

Press enter to exit program.
I Manually checked all the details too.
There is only one item in the ‘Driver files’ list and it is as follows:

I followed your second link and reinstalled the Latest Drivers and nothing has changed. It seems those drivers are for Windows 8.1 and they were already installed.

I Uninstalled the Drive and restarted the Laptop which installed those drivers again and the one item is still there in the list.

I followed the instructions to find the GEARAspiWDM Filter Driver and the details do not follow suite as in the picture in your link.
My picture:

Your link picture:

Any idea how I can get the other items in the list?
I’m not a computer programmer but I’m willing to try any other ideas.

If you do a search for “GEAR Install Uninstall” you will find the full process that is needed to sort this problem out.


Thank you Jim,
I’ll try that now.

This is just ridiculous. I’ve run the GEARAspi Remover software and nothing changes. What a way to spend the whole of my New Years eve! It’s just another day wasted, again!

I have tried everything and still no joy.
Any ideas?

Hi bob99
I have run through this to the ‘T’ and GEARAspi Checker says:
GEARAspiWDM is not running
Driver verification has completed.

Drivers are not correctly installed. Error 1000000.

When I first tried this all those hours ago it said ‘‘Error 3000000.’’

After carrying out all your fixes the Driver Details General tab now shows this Device status

''Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

{Bad Image}
%hs is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0x’’

And now there is Warning sign on top of the TSSTcorp CDDVDW SU-208GB Drive in Device Manager

I’ve worked through all of these in this list too:

When I work through this lot and do everything then NCH Express Burn Disc Burning software and Windows Media Player Burning works fine but WaveLab Elements 9.5.40 still does not recognise the drive.
However, when I do all your fixes the Warning shows up and neither the NCH or Windows Media Player Burning software work.
WaveLab Elements 9.5.40 still does not recognise the Drive!

It seems to me that the problem lies with WaveLab Elements 9.5.40 because the other software recognises the drive with no problem at all.
I really hope we get this sorted. It’s nearly midnight and I almost been sat here all day.

Thank you for your help so far bob99

This is what i tried to send to Windows. It wouldn’t Submit it in the Submit Question section for some reason… luckily I saved all the info.

''CD/DVD-ROM Reader/Writer Device not being seen by WaveLab Elements 9.5.40 in Windows 10 Home, Version 1809, OS Build 17763.195
I am having problems with my Laptop again. I say this as I have had similar problems previously in the link added below and this time those fixes are not working.
Is there any chance someone can help me sort this out again?
I have sent a Support Ticket to Steinberg and also posted in the Steinberg Wavelab Elements Forum and all they say is that the GEARAspi Drivers are not installed correctly. They are are aware of a problem and have been in touch with GEAR and GEAR have subsequently created a tool to remove the GEARAspi Drivers but this has not sorted my problem out.
NCH Express Burn Disc Burning Software has no problem Identifying the CD/DVD-ROM Drive in question (TSSTcorp CDDVDW SU-208GB).

Device Manager
Open DVD/CD-ROM drives
Right Click
General tab under Device Status states that ‘The device is working properly.
Driver Tab
Driver Details
Driver files: C:\WINDOWS\system32\DRIVERS\cdrom.sys
Provider: Microsoft Corporation
File Version: 10.0.17763.1 (WinBuild.160101.0800)
I’ve Uninstalled the Drivers and Rebooted and then also used the GEARAspi Remover tool to try remove the Driver and then Rebooted and I’ve also then supposedly Installed the Driver from this link:
and nothing has sort out the problem.
If the NCH Software is seeing the Drive then why is WaveLab Elements 9.5.40 not seeing the Drive?
I’ve gone into Regedit and followed these instructions (To remove the GEARAspiWDM entry double-click UpperFilters and, under Value data, remove GEARAspiWDM > OK )
I’m not really sure what to do here. IF Wavelab is using the GEARAspi driver then should I have removed the Value data under UpperFilters and having a look in the location, there is no LowerFilter there either.
When I try follow the Steinberg links they posted here:
Then the NCH software stops recognising the drive and WaveLab Elements 9.5.40 still does not recognise the drive.
I’m totally confused and am not a computer programmer at all but I recon I’m getting pretty good at trying to figure things out doing all this. Alas!
Nothing I do helps.
Please help me sort this out. I’ve tried to give you as much information as possible. If you need anything more then please let me know.
I am looking to remove the NCH software and just use WaveLab in future so, if NCH doesn’t use GEARAspi and WaveLab does then I’d be happy to follow what I have to do to get Wavelab seeing the CD/DVD-ROM Reader/Writer Drive so that I can just work with that.
I look forward to hearing from someone.
Kind regards,

Hi PG and bob99

After carrying out the items in the link below this is what the Device Manager shows:

It seems the the GEARAspiWDM Driver that is added to the list in the Driver Details is causing the other programs to not see the Driver but as soon as I remove the Regedit Upper and Lower Filters in the specified location and then Restart, the Warning that appears over the TSStcorp Drive in the Device Manager disappears and the other programs work with no problem again.

For some reason when I follow your instructions bob99, the Warning appears and the other programs do not recognise the Drive anymore.

Either way, WaveLab Elements 9.5.40 is not recognising the Drive for some reason.

Happy New Year by the way.

I hope we can sort this everyone because I’m about to give up and chuck all this computer lark and go hardware.

Thank you for all your help so far.

Kind regards,

Do you have a system restore point to go back to shortly before discovering the CD drive wasn’t working in Wavelab? That’s where I would start. Then going into Device Manager and seeing if things look normal.

If you did Method #5 in that list, that’s apparently what exacerbated all this 10 years ago because Microsoft had a Method 5 back then too. And it plays havoc with Gear. If you did Method 5, you need to either do the registry fix, or run the correct Gear removal routine (Run removal app, (part 1), Reboot, Run removal app again (part 2), Reboot), and then run the Gear Driver Installer - Install or Repair.

Back then it was iTunes (as well as Wavelab) being affected, which prompted the ccm fix.

Hi bob99
Thank you for this.
As soon as I have a gap I’ll try everything again. Thank you for the in depth answer.
I’ll report back again as soon as I get it sorted… or not… lol.
Kind regards,

No restore point when I discovered that WaveLab never worked with the drive.
I never knew WaveLab had the CD creation feature until the day I read about it in the Manual and then tried it.
I was looking to upgrade to Pro but thought that it would be useless if I couldn’t write CD’s or use the feature on my laptop because of this issue.
Hopefully I’ll get it sorted and will get back to you as soon as I do.
Thank you for the detailed description of how to this time. Much clearer than the other post.
Chat soon.
Kind regards,

Hi bob99

I have run though the routine exactly and it still isn’t working.
I think we’re at a stale mate at the moment.
I know if I could get help from one of the Steinberg Team by way of a Team Viewer session that they would spot what is wrong but it seems no one is interested in my help ticket posted in MySteinberg a week ago.
I have had help through them before and everything was sorted pretty quickly once my ticket was actually noticed about three months later.

I’d be interested t see if anything else could be done to get this sorted.
You have been great so far and I thank you for your time and effort. Much appreciated.
I look forward to any further assistance.
Kind regards,

I don’t know what I’m missing in your descriptions, but that may be part of it. Last time I checked the removal tool does all the manual removal does. It lists it’s operations as it does them.

You could try it the old way.

Gear manual removal:,_removing,_64_bit_versions,_etc

Then reinstall the Gear drivers:

Also did you try just the fix, adding just the Upper Filters Gear entry ?
If you go to that registry key now before doing anything, is there an existing Upper Filters entry, or not?

“Go to the registry (start->run->regedit.exe) and look for “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}”. Select it, then Right click in the right section of the window and select “New->Multi-String Value”. Name it “UpperFilters”. Right click on it and select “Modify”. Enter “GEARAspiWDM” into the “Value Data”. Press Enter to move to the next line, then click OK. Restart the computer and it should be fixed.
If not also try to make a “LowerFilters” and leave it blank.”

And reinstall the Gear drivers if needed: