Large Template slow when navigating


I have just under 1000 track template and I have a start midi cc1, cc7, and cc7 controller data for every track like most people have so you can just play it and every instrument is set to the tempalte levels.

However everytime I move my cursor or go to the locator (basically jumping around the session) it lags for a couple seconds because it keeps reading every track’s controller data. I can see this because the fader on each track lights up.

Is this normal? Or can I somehow set it to only read when I press play not when navigating?


Could you add your system specification to your sign, please?


I added my software and 2 rigs to the signature let me know if I should add more.


Thank you. Most often we also provide Windows/macOS version.

Where is the MIDI track routed to? To VEPro6? Which VSTi? Is it the same for alk MIDI Tracks?


I run both pc machines with windows 10 I added that to signature as well.

I have all the midi tracks routed to 6 instances of vepro6 racks (winds,brass,percussion,keys,choir,strings) in cubase split between 2 vepro6 servers-- one on my master which also host cubase and the other on my slave which only job is to host the 2nd vepro server. I have roughly 30-40 channels per instance with some kontakt channels having 1 instrument on it and others have 16 basically for organization and mixing purposes. I also split the outs of multiple channels so there not all routing to stereo out, I basically have like for the “brass instance” I have outs for “horns long, horns short, trumpets long, trumepts short, etc etc”. All this runs back into cubase. I host no instruments besides vepro6 racks inside cubase. And last thing I use the vst3 vepro6 plugin when adding the rack incase that makes a difference.

Let me know if I can be clearer on something. Thank you. :smiley:

So it chases and sends out thousands of MIDI messages every time you transport? Hmm…

Yes exactly which makes everything so sluggish which I think is weird because I believe I have a really powerful setup/machines so I dont feel 1000 tracks should make it sluggish. So I believe I have something wrong maybe a setting I dont know. Hopefully someone here can enlighten me. :smiley:

Try changing the settings here, such as disabling “chase not limited to part boundaries”.

Hi Djw,

Thank you so much. That definitely seems to fix the problem I disabled “chase not limited to Part Boundaries” and no longer when I’m navigating via transport it is sluggish and I noticed the midi channels aren’t lighting up. However when I press play the midi channels all read the data as intended. So working perfectly now thank you so much.

Just for my own curiosity I did some testing with disabling certain instances of vepro6 or trying the cubase session on a sdd vs hdd. Overall I found out that even when cubase is not connected to any vepro6 racks – I even removed them but still had the 1000 midi tracks with midi data with the “chase no limited to Part Boundaries” enabled… I still get a sluggish transport. Not as bad as having the vepro6 enabled but still sluggish.

I’m happy to disable “chase no limited to Part boundaries” but I’m just curious why its getting sluggish so early. Do you think its my system or something else? I still feel its strange to be so sluggish only at 1000. Does anyone else have a similar setup to mine and feels the sluggish?

Cubase isn’t perfect. I probably learned the word “sluggish” on this forum.

hey DMDComposer - I believe I had a similar problem a couple years ago, and I found that the amount of CC data was causing the problem. I started using (menu) Midi > Functions > Thin Out Data, and that solved the issue for me. I am in the habit of selecting the data & hitting that macro for every part in my project. Every once in a while it strips too much, so you do have to pay attention. The only thing I leave as-input is pitchbend data; it seems to ruin that.

I agree with DJW’s signature: I would love to have bezier curves for automation & CC data!