Latency and metronome

I have the trial of dorico 4 and when I’m trying to record a composition of piano it has 10 ms of latency how can I have less latency?
And how can I put minimum volume for the metronome sound?

Welcome to the forum, @Narci_A. You can compensate for latency in Preferences:

(See also the “Changing the MIDI latency compensation value” task at the bottom of that page.)

You can adjust the volume of the click using the fader for Dorico Beep in the Mixer, which is at the very left of the Mixer.


I’m recording with mouse at the moment.

But as you can see in the image (I have installed Asio) I have opened generic latency and asio. And at the moment I record with 10 ms with generic latency.
How can I record with 0 ms latency?
Thanks for metronome volume.

I believe in general zero-latency recording and playback is not possible with the kinds of built-in audio hardware devices included in most Windows PCs.

Due to finite processing capabilities of PC CPU’s there is no such thing as zero latency. It cannot be achieved because a CPU cannot process instructions in zero time. Simple as that. There are many ways to minimise latency, with caveats about that affecting other audio aspects. You can read about that topic with a google search which will produce a lot of results. Something we have to live with, I’m afraid.

Using an external USB audio interface such as the ones from Steinberg or PreSonus or Focusrite, for example, will help you acheive the lowest possible latency compared to inbuilt Windows software.




I’m recording with keyboard pannel, and it sounds after the click.
I have tried to play the first note of 1/4 and it appears before on 4/4 tempo as you can see in the image.

So how can I hear the sound of the keyboard pannel just when I click?


What playback device are you using? Are you using the default HSSE+HSO (Pro) playback configuratoin, or something else?


Yes, that.


The reason I ask is that it should be possible using the default sounds to achieve a reasonably snappy response. Can you go to Edit > Device Setup and check what buffer size setting you have chosen there? If it’s set to something large, try reducing it by one or two steps.


I have 10 ms in generic low latency.

But I say when I click in the keyboard pannel it sounds after the click.
And the helion keyboard sounds right.
As you can see in the image left piano sounds nice

Can I record with that keyboard?

You cannot, I’m afraid: no MIDI is received by Dorico from the keyboard in the HALion interface. Do you have the option of connecting an external MIDI keyboard to your computer?


I have a keyboard midi tmk 88.
how can I do to do sounds?
It produces green lights when I pulse the keyboard but with silence.


A quick web search suggests to me that your keyboard is a Studiologic TMK-88, which doesn’t have any sounds of its own, so it is indeed the case that you need to hear the sounds made by Dorico itself rather than coming from your keyboard. Can you check that the Enable MIDI thru option is activated on the Play page of Preferences?