Latency issue while using amp sim plug-ins

Hi everyone. I’m using the latest version of Cubase 11 pro on Win 10 with all the current updates. When I open an audio track to record DI from my guitar while using Neural DSP’s plug-ins, I am experiencing a very slight latency, enough to throw everything off the click track. I have tried with both my audio interfaces (MOTU 624 and Focusrite Scarlett 2i2 3rd generation) and used direct monitoring from them as that option is grayed out on the setup. The issue remains. I also tested the exact same setup in Reaper and had no issues at all. My buffer is set to 128 for both interfaces which is the lowest I can get without experiencing cracks and pops.

Has anyone else experienced the same and is there a solution for this or is it one of Cubase’s problems? Thanks in advance.

Maybe you have a plugin with a higher latency like a Limiter somewhere in the signal path that you don’t have in reaper

I do have plugins doing processing on drums and on my master, mainly EQ, compression and limiting. I will try and disable some of them and see if that changes anything. Thanks for the reply.

You can enable the MixConsole to show the latency for each Channel to help narrow it down.

You really don’t want inserts on the master while recording as they will introduce latency. You will also get an increase in latency if you have effects inserted on the track you are recording.

By the way why would you have inserts on the master bus before you have mixed the track?

I have plugins on my master all the time as well and plenty of them don’t introduce latency.

The ones on the drums most likely won’t make a difference but a Limiter on the master most likely could be the culprit.

Why would you have plugins on the master all the time unless it’s for room correction?

Why not?
Why does everyone think the way he does it is the only right way?

Thanks guys for the answers. I will start experimenting with turning on and off my plugins on the master and see how we go. Also, mlok got me thinking. Although I like how the track sounds beefed up and all the instruments glued together, maybe when in the recording process, this is not necessary.

You can also use the Constrain Delay Compensation button. I find it very useful in this situation.

https://steinberg.help/cubase_pro_artist/v9/en/cubase_nuendo/topics/vst_instruments/vst_instruments_constrain_delay_compensation_c.html

As a rule of thumb, you should disable every other plugin when recording something that latency could affect its performance. You can pinpoint which plugin causes the most latency like someone above said. Also keep in mind that NeuralDSP are particularly resource heavy. Have you tried if another ampsim causes the same latency?

After trying a few different things, I found that only by removing the plugins that cause latency solves the problem. Turning them off is still affecting latency. And the comments above helped me investigate and pinpoint the issue. Plugins such as limiters, EQ shaping (like Soothe) and tape saturation, do cause significant latency. Once I removed them from certain channels everything was OK. So now, I will see how I can save the channel with the inserts as a preset and load them when finished recording.

They shouldn’t affect latency, as long as you are actually deactivating them instead of just bypassing them (hold Alt/Opt while clicking on Bypass Insert button). Bypassed plugins are still processed.

Though I suppose if you have a project with hundreds and hundreds of tracks deactivated plugins still might create some overhead.