Latency issue with external midi devices

Hello crew :wink:
I’ve delved into the project synchronization and firstly
Which out of the choices of Internal/midi/Asio time code is the best to run with ? as i’m trying to solve a midi latency problem with all three different midi interfaces so it’s not an isolated case . Ive always just left the setting as they are and ticked the sync box for the midi interface ports .
Whats happening is i’m setting up the timecode and sync for the device to start/stop and follow the project time code , i can see every time i press start on the CMC Tp the Motu midi channel light blinks instantly as a message is received but the sync starts aprox half a second after that , if i disable the plugin’s ,turn of DC with my Asio buffer size at 64 (2ml seconds ) im still having this issue .
In the sync panel i have the appropriate boxes ticked for syncing the device but this is happening with all external midi’s
Has anyone got any idea’s , im sure it’s user error as per normal or shall i scream BUG :grin:

Cheers

Hi,

This has nothing to do with the sync. This is how Cubase works. Once you hit Play, Cubase doesn’t start playback immediately. It needs some time to “boot up”. This is how is Cubase working.

Martin , thanks for your reply but …
Cubase it’s self plays instantly but the lag to my external midi devices via all midi interfaces remains out of syn approx half a second behind , and are un useable from the start . It’s not how Cubase works . Never had a sync issue since SX so … , this is why i’am asking

Hi,

Do you send MIDI Notes from Cubase to the external hardware, or does the hardware produces some MIDI Notes by itself (arpeggios or something like this)? In the 1st case, you don’t need any synchronisation neither. All is in sync from Cubase. In the second case, you would need a sync.

Do you use and External Instrument within Audio Connections? Isn’t any Delay set here?

Isn’t the Track Delay in Milliseconds set to any positive value on the track by mistake?

Im using the steinberg start/stop to trigger an external hardware sequencer and using the cubase clock via midi with the sequencer , once the sequencer is left running for 8 bars it syncs but because it starts half a second behind my cubase project it’s out of sync . As i say in the OP , the midi activity light on the channel of my motu receives the command instantly but takes half a second to trigger ,this is the same case with my RME midi and Novation Midi so it’s not an isolated case it must be a setting somewhere , well hopefully , so it is a sync issue , syncing external gear with Cubase via the transport .
Im not in a rush to get this sorted and i have tried afaik all setting in the transport setup , and Asio setup , all plugins have been removed , not just disabled , DC doesn’t make any difference , so here i am ,thanks for your time :smile:

hi @FilterFreq,
So it is not timecode issue but MIDI clock am I right? If you are trying to sync drum machines and external sequencers, that’s MIDI clock you are using. MIDI TimeCode is for different sync method that does not involve Tempo. Please try to avoid using the word “timecode” when it is not the case.

For MIDI clock sync, you have to make sure a few things.

“Always Send Start Message” needs to be turned ON for devices like TR909, 707 and old machines that only starts from the top of the bar when START/CONTINUE messages are received.

“MIDI Clock Follows Project Position” needs to be turned OFF for old devices that do not understand MIDI SPP messages. Also OFF for any device that is not running in “Song” mode when the device is just looping a few bars.

Since Cubase11, you can now use the external instrument for MIDI clock devices. MIDI clock sent to ext. insts. are now very properly latency compensated. You can even insert different buffersized plugin to its return and they all stay in sync. (e.g. set up a TR909 individual outs to external inst, send midi clock to it and insert UADs to BD and so on, all tracks stay in sync with the rest.).

If you haven’t, please try to set up an external instrument and send MIDI clock to the external instrument, not to physical MIDI port. You’ll have to make sure you are sending MIDI clock to the right destination as there are a few little confusing glitches left for naming external instrument and midi clock ports.

Hi and thanks for your response , all of these have been done apart from the External inst just for the fact of using the midi start/stop messages , ive never had to do this before , i have C8.5 installed and C10/10.5 and all setting are exactly the same and non of the other versions have this issue .
I will try the external inst but that seems a bit odd just for the start /stop midi sync messages
Thanks

Ok
After faffing about for ages yesterday , ive managed to get the sync to work for all external Midi devices , i haven’t got a clue how but no more issues , it seems the sequencer which does not require to be used as an external instrument ( because that will just waste audio connections) was for some unknown reason getting confused with other midi data sent through the channels and causing a feedback loop .
All working fine now