Latency Issues /Cubase 9 Artist

Good evening Cubase Fam,


Bought Cubase 9 after using Cubase 5 for years. When recording vocals on Cube9 there is a delay no matter how low the buffer is set to. While recording in Logic everything works perfectly. I usually record on 512 (buffer). I have a M Audio Fastrack c600 and downloaded the latest driver and it didn’t work. I troubleshooted on my presonus audiobox and got the same results. A delay!!! I record on a mac mini /i7 processor/ 16 gigs of memory. Someone, can you please advise???

I’ve also got horrendous problems with latency. I’m using a Kronos 2, Acer i7, and an L6 Toneport UX2. The Cubase click (beep), MIDI tracks and audio tracks are all out of time with each other. If I hit a key on the Kronos, it sounds about half a second later - I’ve got local off and MIDI thru active.

Given that the beep is out of time with MIDI tracks, MIDI tracks are out of time with audio tracks, and the Kronos sounds half a second after hitting a key, there’s no way of recording anything in time.

I’ve searched this and other forums and can’t find any solution. At the moment Cubase 9 is completely unusable. If anyone’s got any ideas let me know!

Would anyone have a solution to this latency nonsense? I haven’t been able to record vocals since upgrading to Cubase 9!! I have a lot of disappointed clients!!! I wont even say how I’m feeling in the inside as I have used Cubase for over 14 years and never had a problem I could not fix… any suggestion? I’m thinking I’ll just have to wait for an updated driver that fixes all of the issues that we are pouring out on here,

I have FastTrack Solo - and it has a Direct monitoring button to shortcircuit input while recording.
Anything like that?
You can always let reverb tails comes through not making it so dry.

I mean buffer of 500 samples and no audible delay, that is not possible to monitor through daw like that.
128 samples is the limit, and rather 64 do not be bothered. For 96k project, double those numbers.

Does FastTrack drivers have ASIO direct montoring - and is it active on drivers as well as Cubase?
That is another way to shortcircuit/loopback input without going through daw first.

If you worked many years without touching stuff, it’s easyh to forget what you did once many years ago.

There are some settings to consider:
One if to use delay compensation - Constrain delay compensation turn that off
And one for ASIO latency compensation which exist as preference and as track control button too(may not be there as default, enter track controls to tell what is there).

There is usually 100-400 samples response time for all external midi gear. So to make audio line up with midi I enter a negative delay on midi track to compensate. Experiment what your Kronos need. I think my KingKorg need 250 samples, so recalculate to milliseconds in your sample rate used).

If you don’t get it settled with the interface you have, not getting latency down, I suggest turning local on, and preview that way and not through daw - just record the midi.

I have FastTrack Solo - and it has a Direct monitoring button to shortcircuit input while recording.
Anything like that?
You can always let reverb tails comes through not making it so dry.

I mean buffer of 500 samples and no audible delay, that is not possible to monitor through daw like that.
128 samples is the limit, and rather 64 do not be bothered. For 96k project, double those numbers.

Does FastTrack drivers have ASIO direct montoring - and is it active on drivers as well as Cubase?
That is another way to shortcircuit/loopback input without going through daw first.

If you worked many years without touching stuff, it’s easyh to forget what you did once many years ago.

Thanks for the response. As advised, buffer setting of 512 is the normal starting point and to be lowered to 256 if there is latency which has ben tried. 512 has always worked with monitoring with no problems. 256 will use more cpu and shouldn’t have to be used if pc has the right specs. I’ve always reset buffers to correct latency as that is beginner troubleshooting. I don’t use ASIO direct monitoring. I use the inout monitoring. My ASIO is greyed out. The thing is latency happens on the Fastrack c600 and the Presonus audiobox. I don’t have a button for direct monitoring on Fastrac but do on the Presonus. No matter what the buffer setting it is on there is still a delay. I record projects on 24 bit /44100hz.

Ok. I troubleshooted again without using my template. Fresh start. Loaded a track with no inserts and talked while input monitoring. Works great no latency. So I started to add “Cubase” inserts and ran into the problem. I noticed when loading the curve eq (a great tool that was not in Cubase 5) or delay (of course my settings on the delay are set low and not mistaking it for latency) the problem comes back. No high cpu usage meter peaking either. I disarm all the the effects and still get the latency. Next, i start a new project and I load my Waves inserts and there is no latency. What now??? What can this possibly be???

Play with the ASIO Guard settings in the device settings. Also, make sure you are using the dedicated ASIO driver for your sound card. The generic driver sucks.

I narrowed it down to the Cubase insert plug ins. For example-Curve Eq and delay (simple plug ins) usually give it the latency. Once I remove that specific plug in from the track the latency is not there. I noticed that my waves plug ins work excellent on there . I also have izotope vocal synth which uses a lot of cpu but no latency when used. Any suggestions for cubase plug ins that causes this latency? I may have to post a new discussion since its been narrowed down to the Cubase insert plug ins.

Some plugins introduce varying amounts of extra latency to the project. This is normal and isn’t exclusive to the stock plugins.

The stock plugins that add the most extra latency are CurveEQ, Cloner, the multiband processors, and REVerence.

The CurveEQ is a precision tool meant to be used as a last resort and is absolute overkill when recording audio. When mixing, it’s only supposed to be used in the rare event that none of the other EQs can fix the issues in a track.

The Delay plugins are supposed to add very little latency (if any?). In this case you probably did something wrong.

256 will use more cpu and shouldn’t have to be used if pc has the right specs.

Due to your wording, I think you have a little bit of a misunderstanding here.

2 points…
i) Having a higher spec PC wont improve your latency if the buffers are set the same, unless you reduce the buffer. In other words… ‘if PC has the right specs’ you should use 256 (or lower), if you want tighter latency. The buffer setting will be the buffer setting regardless to performance.
ii) 256 doesn’t use more CPU, it just gives the PC less time to calculate, meaning less tracks, inserts etc before errors.

It would be good for others to comment as my understanding is also limited. I’m here to learn too.

Thanks for the response. Believe me I didnt do anything wrong. Curve EQ is used to analyze the frequencies to know where to cut and boost with giving the advantage to see where they are. I dont see why any eq would be over kill. I use the same type in logic pro x. Even if I use the eq to edit after a recording, the track as a whole will have a delay. tried to bypass curve eq while recording and there is there is still a delay. I KNOW IT SHOULD NOT DO THIS…thats what is getting me. I removed the eq from the track and recorded and everything was cool. Then i u used 6-7 waves plugins while recording (just for troubleshooting), worked just fine…

Good ram and a good processor will improve your cpu. That’s why they advise you what the minimum requirements are to run the daw. You will notice how the cpu meter will jump up if use a lower buffer setting and add plugins to the trac. You are correct on how lower buffer setting will improve latency.

Use this free plugin for frequency analysis
http://www.voxengo.com/product/span/

Bypassing plugins isn’t enough to remove their latency. You have to turn them off by Alt+right clicking.

I’m not sure why you just told me that. My comment was to help you understand. Your processor is the CPU. When you use lower buffer setting the CPU meter (which is an ASIO meter) will jump up, not because your CPU is working harder but because you are closer to running out of buffer. Your CPU will be working harder the more tracks we add but we’re on about dropping the latency. I hope that helps. It’s got less time to fill the buffers, to do what it needs to do, hence why a faster one will still perform well on a large project at low latency.

Again, as i mentioned in my previous post, others to comment as my understanding is also limited. I only commented as no one else picked up on your wording. it is hard to find the right words!

256 will use more cpu and shouldn’t have to be used if pc has the right specs.

What i’m trying to say is… If your PC has the right spec, if you want tighter latencies, 256 should be used. It doesn’t use more CPU. You just have less time for the CPU to do what is needed. Your CPU will already be calculating things as fast as possible.

I think it’s the plugins you use that just is the last straw that make you notice latency.
512 samples is hiddeous, unless at 96k.

So 512+plugin delay make you notice it - it’s nothing wrong in Cubase or in CurveEQ either - and you did nothing wrong.

If you use Constrain Delay Compensation the curveeq would be bypassed - at default settings in preferences is zero ms - and that extra would go away.
My own limit is 128 samples to play guitar, but have been running 64 samples for 7 years now. It will push you over to crackles earlier than higher settings, but that is the penalty you have to pay. You just render some synths to audio and continue.

Midi VST instruments are different though for you, since audio does not go two ways as roundtrip latency would be 1024 - just midi in, delay it has is virtually nothing, and then (possible plugins chain delays used)+output ASIO buffer from VST instrument and that is what you hear.

Reason being is because u advised having higher specs wont improve latency and I will have to disagree. As an example. When recording autotune the cpu meter will rise. While recording, if the buffer isnt set low enough latency will occur. I would have to lower the buffer in order to record live with auto tune. Also a good processor/ ram make is run smoother. This is from my own experience.

Thank you sir. i may use this…but cubase 9 is brand new…my frustration comes when i have the plugins but cant use as wanted.

From your reply I can tell you still don’t grasp what i was trying to point out.

“I would have to lower the buffer in order to record live with auto tune.” Yes.
“Also a good processor/ ram make is run smoother.” Yes.
“if the buffer isnt set low enough latency will occur.” Yes.
“When recording autotune the cpu meter will rise.” Yes, but it’s an Asio meter.
“u advised having higher specs wont improve latency.” ERM!
A higher spec PC will improve latency time… If you set the buffer lower.

Non of the above quotes are why I pointed out your confusion here.

256 will use more cpu and shouldn’t have to be used if pc has the right specs.

The way you’ve worded that line is incorrect, in the 2 ways I originally pointed out.

Here’s some maths for you… setting the buffer at 512 samples, the latency is 512/the sample rate. If the sample rate is 44100 we get 11.6ms of latency, if you want less latency you have to lower the buffer. You could increase the sample rate for lower latency but this would increase your CPU overhead as each plug in now has more data top be calculated. 512 in a 96kHz project 512/96000, is 5.3ms latency. Which is .5ms less latent than a 44.1Khz project set at 215

512 44.1khz = 11.6ms
512 96khz = 5.3ms
256 44.1khz = 5.8ms

The 96 will increase load on CPU as there’s more than double the calculations to calculate.
The 256 will have less time to calculate before your project runs out of buffer.

In both cases having a faster CPU, a higher spec/nicely tuned PC means… You can set the buffer lower and run large projects with out any issues but you have to reduce the buffer to reduce the latency not buy a faster PC at the same buffer setting. The faster PC will run more plugins but the buffer is the buffer. You seem to be confusing how it and a CPU works.

https://www.soundonsound.com/techniques/optimising-latency-pc-audio-interface