latency issues with midi not audio

Hi I have cubase pro 9 running on windows 10 64 I’m getting latency issues when I try to play my superior drummer with my midi keyboard. It only just appears to have started. my audio is perfect no trouble at all. I have a steinberg ur 22 sound card. my midi keyboard is plugged directly into the soundcard. I have the same issues when trying to play groove agent could it be that my midi keyboard is having issues…it’s over 15 years old. could i test this?
thanks for your time kwisjj

Hi why not try putting your buffer setting down a touch or using the delay compensation button?
Your midi keyboard you use should not make a difference in regards to latency. Only other thing is how much RAM have you got on your PC?
I use 32GIG RAM i7 and I use a retro Roland digital Piano with the cheapest usb midi cable I bought of ebay for 3 quid and I don’t have any real notable latency until my project gets heavier and then I use the delay compensation button.

Failing all the above maybe you could use a keyboard that has its own sounds and monitor that while you input your note data and then send the midi data where ever you want (plugin of your choice)

Hope that helps (producer name)

I use EZD2 and this has been happening for many years for me too (even with EZD). It stared back at the time when I upgraded from CB LE4 to Cubase 7. Mine only happens when I drag in a groove. It will be late (which sometimes makes the audio sound early. It does not happen if I record EZD or EZD2 from the keyboard.

I have always “fixed” this by moving the dragged in midi clips to the left a bit but, more recently, I just use the “Track Delay” function found in the track inspector. The “Track Delay” method should work for you too. Seems like I typically need to adjust the track to something close to -42.50ms. But this number varies from project to project and does not correspond to any latency numbers I can see in Cubase. Except for the previously mentioned workaround fix, I have not been able to find a reason or solution for this. Oh well.

I will say this… if you go into the Devices>VST Audio System menu there are some adjustments that might help with this issue (in the lower half of the right side menu). I never messed with these settings (too lazy I guess). If you happen to mess with any of these settings, and it helps, please report back.

At least you can adjust it with the “Track Delay” function. :wink:

Regards :sunglasses:

Could also be a:

  • latency heavy effect in an insert bus of the instrument channel
  • dont have that vst, but does it have some sort of “wet” heavy delay in the patch you are using?

Are using Drum maps?

I have this problem with Drum Maps activated. If I turn them off, it goes away. Frustrating.