Latency Issues With Track Monitor (Cubase 7 - Cubase 9)

The way I’ve always recorded is with the track monitor on with some plugins on the inserts so I can get a better idea for what the final product will sound like as I’m recording. This has always worked for me, and still does on Cubase 6.5, but Cubase 7 and up get serious latency (delay) on the track monitor. I’ve bought every version since Cubase 7 hoping the track monitoring latency issues would be fixed in a new release but I just tested it out again and the issue is still present in Cubase 9 and it leaves me no choice but to keep using Cubase 6.5. I’ve reached out multiple times about this issue since I first encountered it on Cubase 7 years ago and always get the run around.

Here’s some more information:
Here’s my specs: Cubase 9.0.10, Windows 10 Home 64 bit, Intel Core i7-4790K, 16 GB RAM, RME Fireface UCX
I also had the same issues on my old computer which had a 6 core i7, 16GB RAM, and an RME Fireface 400

  1. I don’t necessarily get the latency at first on brand new projects, but when building a project with plugins it doesn’t take long before I start running into it. The weird thing is, when Cubase 6.5 starts to hit a wall with VST processing power, instead of introducing a ridiculous amount of latency it just starts to crackle which is easily fixed by simply raising the buffer size on my Fireface UCX. Cubase 9 eventually crackles too, but not before introducing the latency.

  2. My most recent test I took a completed 24 bit 44.1Khz Cubase 6.5 project that allows for real-time track monitoring in Cubase 6.5 as long as I simply bypass a few of the mastering plugins, and opened that same project in Cubase 9 to see how it runs. After bypassing the mastering plugins it has unplayable latency. Even after bypassing pretty much every other plugin on the project other than the ones that I need, it still has the same latency. In the VST Performance monitor the real-time peak is bouncing around and constantly hitting the red.

  3. I’ve played around with the buffer size on my Fireface UCX and it doesn’t make a difference.

  4. I’m pretty sure I have all the same device settings and preferences settings on Cubase 9 that I have set in Cubase 6.5, however I have done a lot of messing around with changing things in Cubase 9 in attempt to fix thigns and nothing seemed to help.

I’m really hoping this is a silly 1 button fix that I’m not aware of. This all seems pretty ridiculous to me considering there have been quite a few performance improvements made to Cubase since the release of Cubase 7 which all were meant to help with latency issues and CPU consumption but it’s definitely gotten worse.

Please help! I really would like to start actually using this new software I put so much money towards!

Have you tried Constrain Latency Compensation?

It sounds like you use plugins that add latency, which is compensated for.

Yes, and that does get rid of the latency when used on Cubase 9, however all that button does is bypasses a bunch of plugins that are causing the most CPU load and that always includes amp sims. That’s simply not an option for tracking guitars and even for a vocalist it’s extremely difficult to feel the music and get a good performance listening to DI guitars. I could obviously freeze the guitar tracks and anything else that is vital to feeling the music and then enable latency compensation, but regardless I would still need the amp sims working to track guitars. That said, my point is Cubase 6.5 doesn’t require all of this messing around to reduce the latency. The VST performance is obviously far superior in Cubase 6.5 and that makes no sense to me because Cubase 9 is a much newer product and I’ve read about multiple performance enhancements over the years (mostly small but some apparently pretty big changes) so you would assume it at least wouldn’t be worse.

Just to be clear, I opened an old completed Cubase 6.5 project, set my fireface buffer size to 128 samples, bypassed the master bus plugins, created a track with the monitor button on, and the latency was absolutely fine with no CPU overload crackling whatsoever. Then I did all of the above with the same exact project and same exact settings in Cubase 9 and I have this terrible latency I’m talking about.

I push Cubase 6.5 to its limits and never get increased latency. There are times that I’m recording and I start to notice some crackling because the project is getting too big, in those cases I just bump up the buffer size on my fireface a bit and the crackling goes away and the added latency from the buffer size increase is never enough to be noticeable. On Cubase 9 I noticed I don’t hear crackling as often, but the latency is just unplayable. It’s almost like Cubase 9 is adding latency in attempt to avoid the CPU overload crackling. If that’s the case, I would MUCH prefer how Cubase 6.5 handles things. If there’s a setting for this somewhere please point me in that direction. I would really love to start taking advantage of all of the new features I’ve been missing out on.

-DJ

Constrain Latency Compensation actually turns off/disables certain plugins (depending on their location) with latencies that exceed the “Delay Compensation Threshold” (which defaults to 0). For details, see https://www.steinberg.net/forums/viewtopic.php?f=253&t=113330. Unlike disabled plugins, “bypassed” plugins add latency and Cubase’s (some others?) contribute to CPU/DAW loading.

Since it doesn’t really contribute to perceived latency, you should also make sure the “ASIO Guard” is on (its normal setting seems quite effective). :slight_smile: