Latency on fresh powerfull pc :( :(

Hello !

i’m experiencing some latency on my new station, i have an asus rog 750 with a i7 4710hq at 2.5 ghz, 16go of ram and 2 ssd and windows 8.1 i really thought i woudln’t have any problems… i have a focussrite 18i8…

here is what i’m experiencing:

with the asio buffer size of my sound card audio panel is set to 4ms

in the cubase audio option: multithread on / asioguard off / and optimised steinberg audio power on

so i create an empty project, one audio track with guitarist, i plug my guitar and i puta good sound, everything is ok the latency in ok i can play… BUT

if i just add 2 more audio track with one plug in (ozone)

than i have a little latency on the guitar !!! and of course the more tracks i add the more latency get big :frowning:

i couldn’t beleive my ears that a so powerfull machine couldn’t handle something as simple as that :frowning:
i tried multiple configuration (audio guard, multithread optimizing windows etc.) but i couldn’t find a way to play my guitar correctly with just 3 tracks !!!

also with some bigger project i can see that in the performance window that the realtime peak is moving alone and can go to the red even when i’m not playing :frowning: :frowning:
i suspect windows to be not optimized but i tried a lot of tricks i found on internet and can’t optimize it good enough…
is it normal, do you experience this ?? is there some magical setting i didn’t find ??? what should i do ?
any ideas ??

and the ultimate question is : Should i go on mac ??

thanks for your time, i’m really really getting mad on this :frowning: :frowning:

Dan

I guess you are using the Windows 8.1 pre installed from asus with lots of bloatwares (like Mc afee, asus cloud, and all the useless toys (face recognition, vivid video…))

I suggest you take a windows 8.1 iso and start by doing a fresh, clean install with only your drivers and Cubase.

easyer way but no the best is using game optimisation software like : http://www.iobit.com/en/gamebooster.php
and bloatware remover like http://www.decrap.org/

a clean Windows should have about 40/45 processes (mine have only 26 ^^) at startup.

PS : If you are afraid to loose something you could do a system backup with freeware like backupper (http://www.backup-utility.com/free-backup-software.html) before doing anything…

First off, I know you’ve experimented with different settings, but with Cubase 8, ASIO-Guard should be ENABLED and the Steinberg Audio Power Scheme should be DISABLED.

You also want to make sure that the “High Performance” power scheme is selected in the Windows Power Options control panel.

Now, regarding your interface: What sample rate and buffer size are you using? (The focusrite control panel is really misleading with its “ms” slider instead of normal powers-of-two buffer size selection.) I can’t remember if Cubase reports the correct sample buffer size in the VST Audio System panel… it might only list latency and sample rate.

Anyway, the thing with Focusrite interfaces is that their ASIO drivers are really bad, performance-wise. Possibly the worst ASIO latency you can get. A lot of Focusrite users actually use ASIO4ALL instead… it’s a bit of a hack (ASIO4ALL actually wraps Windows audio to make it compatible with ASIO software), but it reportedly works to reduce latency vs. the Focusrite ASIO drivers.

Another thing, though- a workaround is to just use the interface’s direct monitoring mode if the problem for you is just the latency you experience while tracking out guitars or vocals. If you like to be able to add effects or processing inside your DAW while tracking, though, direct monitoring might not be an option. In this case, I’d experiment with finding the smallest buffer size you can achieve without getting audio glitches and/or trying to use ASIO4ALL instead of the factory drivers.

Hi

I would turn asio guard on and avoid Ozone for recording.

Ozone has very high processing latency, which is ok for mixing or mastering.
If you have it on master or directly on a track you are recording, it will add a lot of latency.

Thanks everyone for your answers ! Misohoza you made my day !!
i was used to use ozone that i find really great directly on tracks to use the EQ, and i just tried to bypass them to test if they was the problem… Now i tried to unload them and everything is working as expected !!
well i understand it should be used for the mix but it’s Incredible that just more than 2 ozone plug in could add as much latency…

i unloaded them and now i can record my guitar with guitar rig live on my big 20 tracks & Vsti projects too !!!

GREATTT thanks :slight_smile: :slight_smile:

Hi,

I’'m glad to hear that you were able to reduce the latency in your sessions.

Additionally there are some steps you can take to optimizing your PC for audio. These steps will often times improve issues with glitchy audio and latency.

Here are the steps for optimizing your PC for audio:

http://us.focusrite.com/answerbase/optimising-your-pc-for-audio-on-windows-8

I’m not sure which version of Scarlett Mix Control is currently installed, but we do have newer versions available on our beta site. These newer versions improve issues that were present in previous versions. Here is a link:

http://beta.focusrite.com/releases/scarlett_mixcontrol/

If you experience any issues in the future please feel free to give us a call at 310 322 5500. Phone support is available Monday-Friday 8am-6pm(PST.)

Best Regards,

Derrick // Focusrite Technical support