Latency problems

Hi there

I’m using Cubase Studio 4 on my laptop connected via USB to a MOTU 828 mk3
For drums I use EZ Drummer. All other MIDI sounds is coming from my MOTIF ES6, connected through the MOTU
The EZ drummer and the MOTIF is not in sync. I have a slight latency on my EZ Drummer (when using drums from the MOTIF there’s no problems)

Is it posible to lower the latency on EZ Drummer or maybe add some latency to the external MIDI?


Have you selected you audio cards specific ASIO driver from within Cubase?

What is your latency set at within your sound cards software interface?

Do you have ‘Direct Monitoring’ enabled within Cubase?

If you hit the drums in EZDrummer with your computer mouse, do you hear that drum instantly, or is there still a delay there too?

I have selected the MOTU ASIO Driver.

With sampling frequence 44.1 kHz and 512 samples pr. buffer i get the following latency: in = 12.8 ms. / out = 23.6 ms.
With sampling frequence 44.1 kHz and 128 samples pr. buffer i get the following latency: in = 4.1 ms. / out = 6.1 ms.
With the first setting I get too much delay. The second I can live with, but it would be nice with more ways of tweaking.

Direct monitoring is set off.

I don’t get delay when hitting the drums in the EZDrummer panel.

I have experienced a couple of system locks (Cubase not answering) since I started using EZDrummer.

I don’t know why EZDummer would cause system locks, unless maybe you’re using a 64 bit OS with a 32 bit version of EZDrummer, and trying to use some kind of ‘bridge’…?

I was using EZDrummer just fine on my old Win XP DAW, which was a single core AMD @ 1.6 GHz CPU with Cubase VST 5/32. I could trigger it fine with my midi keyboard & midi edrum set. Sure there’s was some amount of latency, but livable. The only any real problem if I had too much going on with the entire project and I had to greatly raise my latency.

Have you also tried ‘using’ Direct Monitoring?