Latency & Render

HI I am having 2 major issues with Cubase9pro which is causing me a lot problems, First I’m having latency problems whatever VSTI sound I play clipping/popping sounds because of latency. But I don’t have any problem with external keyboard sounds and wave channels this happens only with VSTI sounds kindly tell me what I can do to sort it out. my pc info…Picture
Secondly when I render VSTI sounds I want quite a few sounds in MONO but I don’t have option to render in Mono only stereo please guide me step by step on what I can do to be able to render sounds in Mono easily.
st.png

Hi,

Try to increase Buffer Size.

And try to test your system via LatencyMon.

Sorry but could you kindly explain a bit more about this how can I increase Buffer Size and where can I find Buffer Size option?
Also how do I “test system via LatencyMon” please guide step by step sorry for any trouble because I don’t know about these two things is this option in Cubase or PC?

Read the RME manual

LatencyMon is a third party software that can help diagnose driver or hardware problems that interfere with audio playback. Run it for a while (5-10 mins should do) with Cubase already running and then stop it and see what the report says.

http://www.resplendence.com/latencymon

Hi Sunny7, what sound card are you using, you can change the buffer size there or in Cubase at the studio setup (Pro9.5)

It will not Render to a mono track, what I do is, export the track in question as mono to the desktop,then bring it back in to Cubase to a new mono track.
Hope this helps
Alec

PS I sent more requests to Steinberg to get a render to mono, but it fell on stony ground ! lol
Like, who ever records a kick or snare in stereo lol lol

Hi thanks for reply Grim I played LatencyMon but I don’t understand how it is working because even before I pressed start it had a message saying that "my system is suitable for handling real time… " (please see pic) still I carried on and done exactly what you said to run it while Cubase is running but the msg was the same after 10 mints I don’t know what any of the bottom part of the pic means at all but I still have the latency problem ? what is going wrong… confused! Basically I want to clear up my latency problem please guide me

Well your result saying it’s suitable is a good thing…but your highest execution is still higher than ideal. Can you sort the driver tab by highest execution and screencap it.

Have you checked what buffer settings you have in the RME yet??

Export to mono is an option in the export dialog. Not sure what you’re missing there. Confused why you would want to export in mono and bring it back in … why not just keep stuff on mono tracks? I’ve exported mono stems to be imported to other DAWs, so maybe that’s what you want to do. BUt usually, just keep it in Cubase.

The clicks on VSTi are because internal synths are using CPU and computer bandwidth. The combination of that CPU load and your computers ability to process the sound in the amount of time (latency) it is currently set to is not sufficient. Your external stuff doesn’t pop and click because it is not asking the computer to make the sounds. You really need to find that buffer setting on your audio interface.

Just pitching in what solved my latency issues:

  1. In Cubase 9.5.10 open the menu option Studio -> Studio Setup…
  2. Try selecting the “64 bit” processing precision, “Boost” audio priority and select “Activate Steinberg Audio Power Scheme”
    (see attachment nr 1 for a screen dump of the settings I used)
    This fixed my issues.

I did not have to change my buffer settings for the ASIO driver but in case you wish to try that you will find the setting like this:

  1. In Cubase 9.5.10 open the menu option Studio -> Studio Setup…
  2. Select the “Generic Low Latency ASIO driver” or whatever audio driver your system has.
  3. Click the button labelled “Control Panel” (see attachment nr 2 for a screen dump of this dialogue).
  4. You should now see the actual control panel for the driver and this is where you will find the buffer setting (see attachment nr 3 for a screen dump of this dialogue).

Hope this helps you solve your latency issues.
Cheers!
/Mats



Hey sorry but I made a mistake I started latencymon before running Cubase and it gave me the report that I sent you but today I turned on my PC ran Cubase and then turned on LatencyMon and please see pic there is quite a few problems but I don’t know what to do next please could you help me kindly. Also I have sent a screen shot of RME UCX setting to see the buffer size but I don’t know if I should increase/decrease the buffer size what settings should I set this on for Cubase. If I increase/decrease the buffer size too much can it harm my sound card I cannot take the risk kindly tell me safe way of doing this.
Please note I have sent all screen shots and a Stats note pad files in zip folder, please give me your analyses on what should do net. Thanks.
Screen shots and Note pad.zip (211 KB)

OK…256 is an OK buffer size for this interface. You should be able to run a reasonably busy project at this setting
If you increase the buffer you may be able to help with the clicks and pops but you will also have higher latency when playing the instruments. Of course it can not harm the sound card…otherwise they wouldn’t let you do it.

Firstly you can ignore the bit about your cpu speed…the problem is with your dpc latencies and some driver or setup issue is causing it.

I’m not sure when I’m next around and missing some details on your system to do much more than guess some tweaks that may help but certainly won’t hurt. If you don’t understand just Google, they are common things to do so there will be step by step instructions if you need them.

  1. Set Windows power settings to high performance
  2. Not sure if UCX is on USB or f/w but if USB then you must disable selective suspend - Also in device manager for every USB HUB open and undr power management untick allow computer to turn off this device
  3. Uninstall all Nvidia software - Download latest installer, run a custom install and untick everything except the main graphics driver.

This helped me just yesterday. Was experiencing a lot of drop outs after Windows fall update.

Here is the link for Win 10:
https://www.sweetwater.com/sweetcare/articles/pc-optimization-guide-for-windows-10/

This is for Win7:
https://www.sweetwater.com/sweetcare/articles/pc-optimization-guide-for-windows-7/

I did the step by step for Win 10. I did everything except Disable User Account Control.

All dropouts disappeared & my vst performance was improved by over 50%. Very happy camper now!

Mike

In their guide they state:
“Under Processor Scheduling, select Background Services”
That is wrong Cubase and audio drivers are not background services, this will decrease performance, although only by a little.
But everything else looks good.