latency with virtual instruments

Hello .Since the 9.5 version of Cubase Pro , I have some latency with virtual instrument (BFD 3).
I can’t record tracks naturally.
Can anyone help please ?


Hi and welcome,

There is always a latency.

You can change it in the Control Panel of your Audio Device. In Cubase open Studio > Studio Setup, on the left side, select your ASIO driver, and click Control Panel on the right side. Here you can change the Buffer Size/Latency of your Audio Device.

Hi there. I am a complete newbee, and trying to set up (9.5Pro) to be workable.
I’m finding the latency to be really annoying when playing in keyboard tracks etc. What is a good level to set buffers at? I understand there is a trade-off…It is currently set at 10 milliseconds.

Depends on the lowest your specific interface and computer and project will allow. Note that reported latency can be misleading and actual latency will be a little higher in most cases. If you can go lower without drop-outs then go lower…you may need to adjust back higher as your project progresses.

Also make sure you either don’t add plugs with additional latency or use the constrain delay compensation button to temporarily disable them.