Latest Cubasis update 3.4.3 is not smooth

recently I have purchased Cubasis LE with full features iPad version. It was working fine till the last update but after the update of v3.4.3 on iPad it’s not working properly. Its taking lot of time to load the application and lot of glitches when dealing with interapp or AUV3 recording. It was not like that initially but with the latest update it was not smooth. Hiccups in audio recording. I believe something needs to be fixed from Cubasis end. I am using geoshred as inter app audio but not able to play smoothly while recording. The same I have tried with GarageBand it was so smooth. Then I realised there is a problem with cubasis update. Another problem is tempo, when I use geoshred as AUV3 plugin it must be sync with cubasis tempo but while playing the track the notes are shuffled so final output is horrible. So could you please let me know why it’s happening.

I am using iPad 7th generation model.

Hi @sree_pentapalli,

Thanks for your message and a warm welcome to the Cubasis forum!

Please give the following steps a try:
(1) Load the “New Project” project template.
(2) Close all running apps, including Cubasis.
(3) Fully shut down the iPad.

Please let me know if Cubasis will load and work as expected, once you’ve relaunched the iOS device and the app.

& stay healthy,

Hi Lars
I have tried all the all the required steps but it’s always loading with huge delay. I have closed all the apps and running only Cubasis and Geoshred as interapp, but no luck. Main problem is while recording , its not properly recording. It’s recording but not appearing on track. After sometime it’s appearing again . Is it something like iPad 7th generation not capable to run Cubasis 3 smoothly?
I don’t think this is the reason but would like to clarify. When processor is not capable we often see these kind of behaviour.

But I am very strong that it was worked very smooth with 64 tracks of my project but after this update it’s not even able to loading 4 audio tracks. Imagine what could happens if we deal with multiple plugins and multiple tracks.
I am happy to record a video with all the glitches I am facing. So that you can understand the problem.

Kindly advise

Hi @sree_pentapalli,

Thank you for your message.

Please share a short clip with us, which shows the issues and make sure to have the “setup/project” and “setup/audio” pages included in the filming, so we can take a look at the Cubasis settings too.


Hi my name is Ali . My question is when I add Wavestune on my voice track or live singing sometimes it stuck I mean the voice comes wavy or something wrong .I am sure that I am doing all right but sometimes it happens and I power the iPad off /on then I create and delete new projects for too many times then it get fixed but I have to add I feel it happens roughly with all effects .any solution? Thanks

Hi @Ali_Aliyev,

Thanks for your message.

Please share a short clip with us, which visualizes the problem.

& stay safe,

New Project (2).mid (64 Bytes)
Hi this is the issue tha I am talking about

New Project (2).mid (64 Bytes)
Sometimes it is delaying or echoing even There is no effect this is. Track raw .
Ali Aliyev

Hi Ali,

Please share a short clip with us, which shows the steps and issue, to allow our engineering to comment about the issue.