Latest EuCon for latest Nuendo?

From the pdf “Nuendo_5.1.1_ReadMe”:

Avid / Euphonix remote controllers
Nuendo 5 is compatible with Avid / Euphonix MC-Pro, System 5-MC, System 5, MC Transport, MC Control and MC Mix. For operation you need an updated driver. Please visit http://www.steinberg.net for EuCon adapter updates.

I searched Steinberg web, and I found this site:
http://www.steinberg.net/en/support/content_and_accessories/downloads_eucon.html

I installed the only EuCon adopter that I could find: The Steinberg EuCon Adapter for Cubase 6.

After installing, I started Nuendo and opened Device Setup. There EuCon is displaying version 5.0.0.460 built on Apr 19 2010 14:47:44.

So my question is: Is that the correct version for Nuendo 5.1.1?
EuCon.jpg

No that’s for Cubase. Have you downloaded the latest Eucontrol software from Avid?
http://www.euphonix.com/artist/support/downloads.php
The license is on your Nuendo key?
http://www.euphonix.com/artist/products/mc_mix/tour_app_support.php#tour7

Hello Hans-Erik, yes, the EuCon Adapter version 5.0.0.460 is the correct one for Nuendo 5.1.1. This
adapter will be installed by the EuControl Software Package Version 2.5.7 (PC) or 2.5.6 (Mac) Installer
for Nuendo5 like “always” before. Please note that the Nuendo software needs to be installed before
the EuControl software as the EuCon Adapter will be placed in the Nuendo5 application folder (in
components). We just have re-checked the functionality of the EuCon Adapter & Artist controller
using Nuendo 5.1.1. 32bit on Win7 64bit and EuControl 2.5.7 64 bit (PC) which works as expected.
Please note that the new Steinberg EuCon Adapter installer and installation procedure is slightly
different for Cubase6. I hope that helps, best regards, Tino

Thanks for quick response :slight_smile:

Before I posted here, I installed the EuCon adapter for Cubase 6.
Everything is working fine.

But to be safe:
Do I need to un-install EuCon adapter for Cubase 6 and then reinstall the EuControl Software Package Version 2.5.6 (Mac)?

Hello Hans-Erik, thank´s for your reply. No you don´t need to re-install EuControl 2.5.6 after you have
removed / de-installed the EuCon Adapter for Cubase6. Please follow the instruction as given in the
document: Mac: To remove the EuCon Adapter, you are required to manually delete the “eucon60.bundle”
file found under: System hard disk > Library > Application Support > Steinberg > Components.
This will leave the EuCon Adapter for Nuendo5.0/5.1, installed and placed in the Nuendo program folder
untouched. I hope this helps, best regard, Tino

Thanks, Tino - I appreciate your answer :slight_smile:

I am having a similar issue but using the PC and Eucon Adapter 2.5.7
When loading Nuendo 5.1.1 I can see that Eucon is not initializing (on the splash screen). Also it is not present in the device list. I have flushed my prefs and uninstalled and reinstalled but still the Eucon is not in the list. I have found the euconadapter.dll in the component folder and it still won’t work. Nuendo 5 seems to ignore it as it doesn’t show in the Program Plug-in section of the Plug-In Infortmation section.
Thanks so much,

Josh Vamos

Which Operating System?

On Win7 it should be: program Files(x86)/Steinberg/Nuendo5/Components

Fredo

No problems here, but I wish the integration of the panning encoders on the Mix and Control were better with Nuendo. Tested with ProTools 9 on the same machine - perfect. Smooth, sensitive and accurate behavior. Nuendo on Mac, spot on. Nuendo on PC, with the latest PC drivers, panning is jumpy and really inaccurate when doing slow panning or just when trying to pan something a little…

Hi,

I installed N5.1 and my MC (Artist) Mix stopped working. Previously I had installed the Eucon 2.5.7 and couldn’t make it work, then went back to 2.5.6 and that was working. I saw in an early part of this post that 2.5.7 is correct for N5.1/Mac/OS10.6 so I uninstalled 2.5.6 and reinstalled 2.5.7. No improvement.

Also, I tried to follow the path “System Drive>Library>Application Support>Steinberg>Components” and I don’t have “components” at that location to delete.

I also deleted and reselected Eucon in the Nuendo device setup but no change. Any recommendations? Back to 2.5.6?

Thanks for your advice,

Mark

Hi Mark

EuControl Software Package Version 2.5.6 is the latest version for Mac OS on N5.1.

Thanks, Hanza -

Actually I think i mixed up the numbers and have installed 2.56 for the N5.1 and that isn’t working. Previously 2.55 was working before the Nuendo 5.1 maintenance upgrade.

I may try to go back to 2.55 and see whether that wants to work. I believe 2.56 drops the HUI compatibility for the new PT 9 needs.

Thanks,

Mark

I reverted to Eucon 2.5.5 and it’s working fine. Just wanted to mention that the problem is solved until the next round of updates.

Is there another Nuendo 5.1 Mac user with Eucon who is using 2.5.6? I think 2.5.6 is mostly about making the Artist series controllers work with PT 9 and the loss of HUI seems to make it unworkable for my N5.1.

Regards,

Mark

Some of us had similar problems with the 2.5.5 update.

After hashing it out with Euphonix support, this solution worked for me and at least a few others. Might be worth a try for 2.5.6 as well.

**********

This from support:

I would recommend a clean install:

  1. Close all application including EuControl.
  2. go to: ~Library/Scripts/Euphonix Scripts/Utils/…
  • run CleanEuphonix script and reboot.
  1. Repair Disk Permissions. Reboot again.
  2. Download and install EuControl v2.5.5

It could be there are some files that are being left from the 2.5.4 that should be updated by the 2.5.5 installer but somehow are not.

***********

Good luck!

Chewy

Thanks, Chewy -

I keep PT for dealing with projects that come to me in that format (or have to leave in that format) and would like to upgrade my LE 8 to 9. When I do that I’ll have to try 2.5.6 Eucon again and your advice looks really helpful.

Regards,

Mark

Hi,

I’m having the same issue where the Device Setup does not offer Eucon in the drop-down list. I have open tickets with both Steinberg and Avid, and so far the news from Avid Support (Third Party) is that somewhere in the development chain Avid and Steinberg are dropping the ball - that’s a worry. If someone has overcome this issue please help:

PC-Win7-64bit
Nuendo 5.1.1 64bit
EuControl 2.5.7 64bit
Artist Control and Mx - firmware up to date
Steinberg_EuCon_Adapter_6.0_64bit
Properly licensed through eLicenser (download from Steinberg)

The Control unit is application aware, it “sees” Nuendo and has the soft keys loaded and available. The .dll is in the components folder. I have uninstalled EuControl, unstalled Nuendo, reinstalled Nuendo, reinstalled EuControl in and out of safe mode (actually I couldn’t uninstall Nuendo in safe, just EuControl). But still the device setup does not offer Eucon as a device.

Steinberg is still looking into the issue, but if anyone has some ideas I’d love to hear them.

Thanks!

The .dll is in the components folder.

Hi MonsterBoo,
check if the NEWEST(!) dll (5.0.0.460) is in the Nuendo_64bit (!) components folder.
there is another components folder for Nuendo 32bit, if I remember right, the installer sometimes fails to reliably update old versions in all of the different components folders.
Hope this helps,
Bernhard

AFAIK EuCon won’t work with Nuendo 64bit at this stage. This will be coming though as a 64bit EuCon component exists for Cubase 6 (however the current Nuendo 5.1 won’t recognize it).

I can’t offer any opinion on 64bit but for my 32bit N5 on Mac Pro, I did install the 2.7 Eucon update for my fader bank and it worked well immediately.