latest Komplete Kontol dll not being accepted

I am suffering with Cubase and Native Instruments at the moment.
2 problems - Cubase 10.5 pro VST manager does not like the latest (2.4) Komplete Kontrol dll file. It was sent to the VST blacklist so I re-initialised it (or whatever the correct terms is) and it went back into the VST instrument list but its now displayed in bright red. Cubase crashed a couple of times but seems stable at the moment

The other problem is that I can no longer control transport etc from my Native Instruments S61mk2 keyboard although I can select instruments etc. I have tried re-installing native instruments but the file Komplete Kontrol DAW has disappeared - its usually selected within Studio setup/ Midi port setup but I now only see Komplete Kontrol -1 and Komplete Kontrol EXT1.
Any suggestion will be appreciated

I just realised that some of the problem might be caused because we use a shared computer - I have a separate Windows log in account to my son. We share Komplete Kontrol on both accounts so maybe we have separate drivers for our individual log in , He uses Ableton and I use Cubase each on our individual accounts. Anyone got experience with this type of set up

I would make sure when you install, you do it with Admin rights, and make sure if there is an option that you install for all users. Check the NI forum - there are a couple people there with a similar problem. One thing to look for is in the Windows Task Manager, make sure these 3 programs are running:
NIHardwareAccessibilityHelper.exe, NIHardwareService.exe, NIHostIntegrationAgent.exe
And in Services (run services.msc) the NIHardware and NIHostIntegration services are running. These should be set to Automatic start (right click Properties). If they aren’t listed, you’ll need to reinstall.

Also, I’m not sure because I only had to resurrect one plugin, but I think the red highlight goes away after you close and re-open, or at least it eventually disappeared for me. Could be wrong though. Perhaps someone else who is sure could clarify…?

No it doesnt. I have the same problem just with Kontakt 6 and i cant even use it. When i reopen Cubase 10.5, Kontakt cant be loaded. Shame.


why is a configuration error a shame? Shame on you?

did you run Cubase with admin rights after the install?

Thanks SF Green. Great suggestions. I checked the NI exe files and they are there , set to auto and running. The cubase VST plug in manager still has the file highlighted in red.

So after getting fed up trying to sort out problems I reformatted my ssd drive and merged the D drive with the C (so that no confusion between files locations). Loaded all my Native Instruments and several others eg Omnisphere, Ableton, maschine etc. I ran the Komplete Kontrol scan for sounds. Disabled Windows Defender, downloaded a fresh copy of Cubase 10.5 and ran the install program. The only programs on the pc are the default windows programs, Maschine, Komplete Control, Focusrite drivers, Ableton and Cubase. I run Cubase and Komplete Kontrol appears in the VST block list along with various non VST applications. So I re-initialised Komplete Kontrol and its back in the VST list but bright red. Seems to work ok. Seems like a bug in Cubase. I really am surprised that two German companies apparently do not want to communicate with each other both on my pc and in the real world.

One other point - when I go to the media bay, the Steinberg VST instruments etc display in colour but the Native instruments are monochrome. Is this usual ?

Fixed! I had too many (wrong) location paths set for VST instruments.
I deleted all Native instrument locations except one pointing to Native instruments/64 bit VSTs.
Cubase crashed. When I restarted it had added another location with dozens of files added to the black list ( or perhaps that location was hidden on the next page so I didn’t notice it!).
I deleted that one and now finally I have a fully functional system - I hope.
The Native Instrument logos within the media bay are still without any colour but I can live with that unless someone has a suggestion - or perhaps thats how they are supposed to ne?